apport-gtk crashed with ValueError in _apt_pkg(): package rhythmbox-ubuntuone-music-store does not exist

Bug #1055464 reported by Mark Shuttleworth on 2012-09-24
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Unassigned
rhythmbox (Ubuntu)
Medium
Martin Pitt

Bug Description

Apport crashed reporting a bug :)

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: apport-gtk 2.5.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
Date: Mon Sep 24 13:00:46 2012
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100201)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/zsh
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with ValueError in _apt_pkg(): package rhythmbox-ubuntuone-music-store does not exist
UpgradeStatus: Upgraded to quantal on 2012-01-03 (264 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare wireshark

Mark Shuttleworth (sabdfl) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

Part of the issue here is the rhythmbox apport source package hook which contains the following:

    # Check to see if the stacktrace is a webkit or libubuntuone issue
    # if it is, then reassign to the Ubuntu One Music Store
    stacktrace = report.get("Stacktrace", None)
    if stacktrace:
        if "ubuntuone" in stacktrace or "webkit" in stacktrace:
            report.add_package_info("rhythmbox-ubuntuone-music-store")
            return

However, apport shouldn't crash if the package doesn't exist. I'll open a rhythmbox task for fixing the source package hook.

visibility: private → public
Changed in apport (Ubuntu):
importance: Medium → High
Changed in rhythmbox (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Colan Schwartz (colan) wrote :

I was directed here when reporting, but in my case, it was with Skype, not Rhythmbox:

 Traceback (most recent call last):
   File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 113, in _apt_pkg
     return self._cache()[package]
   File "/usr/lib/python3/dist-packages/apt/cache.py", line 185, in __getitem__
     raise KeyError('The cache has no package named %r' % key)
 KeyError: "The cache has no package named 'skype-bin'"

Martin Pitt (pitti) on 2013-10-22
Changed in apport (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

That's because the rhythmbox hook calls report.add_package_info() instead of attach_related_packages(). add_package_info() sets the report's Package: field, which is really the wrong thing to do here.

Changed in apport (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Invalid
Martin Pitt (pitti) wrote :

I'll fix the rhythmbox hook, and install it again (it got dropped from the last merge in trusty).

Changed in rhythmbox (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
Martin Pitt (pitti) on 2013-11-05
Changed in rhythmbox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rhythmbox - 3.0.1-1ubuntu3

---------------
rhythmbox (3.0.1-1ubuntu3) trusty; urgency=low

  * debian/source_rhythmbox.py: Fix rhythmbox-ubuntuone package name, and
    don't call add_package_info() on it if it isn't installed. (LP: #1055464)
  * debian/rhythmbox-data.install: Install the Apport hook again (got dropped
    during merge).
 -- Martin Pitt <email address hidden> Tue, 05 Nov 2013 11:07:26 +0100

Changed in rhythmbox (Ubuntu):
status: Fix Committed → Fix Released

This also affects Ubuntu 14.04 Trusty Tahr (Development Release).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers