apport-gtk crashed with AttributeError in _filter_tag_names(): 'int' object has no attribute 'isspace'

Bug #1052754 reported by Lockal
296
This bug affects 64 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Critical
Martin Pitt
Quantal
Critical
Martin Pitt

Bug Description

apport-gtk crashes inside _filter_tag_names function.

This report was sent by temporary replacing _filter_tag_names function with stub:
    @classmethod
    def _filter_tag_names(klass, tags):
        return tags

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: apport-gtk 2.5.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.20-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportLog:

ApportVersion: 2.5.2-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Wed Sep 19 07:53:43 2012
ExecutablePath: /usr/share/apport/apport-gtk
ExecutableTimestamp: 1347973022
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
ProcCwd: /home/lockal
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with AttributeError in _filter_tag_names(): 'int' object has no attribute 'isspace'
UpgradeStatus: Upgraded to quantal on 2012-07-22 (58 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Lockal (lockal) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Revision history for this message
DENC Netherlands B.V. (automation) wrote :
Revision history for this message
Lockal (lockal) wrote :

automation, you have probably mistyped bug id. Bug 1048156 is about libreoffice, and this one is about apport and python 3.

Revision history for this message
Scott Moser (smoser) wrote :

Marking this critical, as apport (at least 'ubuntu-bug') is completely unusable without a fix.

Changed in apport (Ubuntu):
importance: Medium → Critical
Ursula Junque (ursinha)
tags: added: rls-q-incoming
Revision history for this message
Edward Donovan (edward.donovan) wrote :

So, it was this change:

  http://bazaar.launchpad.net/~apport-hackers/apport/trunk/revision/2487

made to fix bug 1029479, that introduced this function, with this bug in it.

Revision history for this message
Edward Donovan (edward.donovan) wrote :

So here in lines 951-2 of launchpad.py:

        for ch in tags.lower().encode('ASCII', errors='ignore'):
            if ch.isspace() or ch.isalpha() or ch.isdigit() or (len(res) > 0 and ch in b'+-.'):

The first line is creating ch as an int, according to the traceback. And the second line expects a string. I'm not pythony enough to have a quick fix yet. Thanks.

Revision history for this message
Robert S. Flynn (rsflynn) wrote :

Cannot connect to crash database due to this issue. I have had multiple app crashes that have gone unreported.

Revision history for this message
Lockal (lockal) wrote :

Temporary workaround is described in desctiption. Just open file /usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py and replace function _filter_tag_names (near the line 952) by this stub:

    @classmethod
    def _filter_tag_names(klass, tags):
        return tags

Revision history for this message
Christopher (soft-kristal) wrote :

apport was trying to report both a cupsd error and a signon error and crashed.

Revision history for this message
Vivek Taparia (vivektaparia) wrote :

Llot of things are failing and this is happening to me after upgrade to 12.10 from 12.04

Martin Pitt (pitti)
Changed in apport (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
assignee: nobody → Martin Pitt (pitti)
Didier Roche (didrocks)
Changed in apport (Ubuntu Quantal):
importance: Critical → High
tags: removed: rls-q-incoming
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in trunk r2490.

Changed in apport (Ubuntu):
importance: High → Critical
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.5.2-0ubuntu4

---------------
apport (2.5.2-0ubuntu4) quantal; urgency=low

  * Merge from trunk:
    - hookutils.py, attach_root_command_outputs(): Ignore IOError crash about
      nonexisting files, which can happen if the user dismisses authorization.
      (LP: #1051222)
    - launchpad.py: Fix tag filtering for Python 3. (LP: #1052754)
 -- Martin Pitt <email address hidden> Thu, 20 Sep 2012 08:07:01 +0200

Changed in apport (Ubuntu Quantal):
status: Fix Committed → Fix Released
gothundr3 (gothundr3)
Changed in apport (Ubuntu Quantal):
assignee: Martin Pitt (pitti) → gothundr3 (gothundr3)
Martin Pitt (pitti)
Changed in apport (Ubuntu Quantal):
assignee: gothundr3 (gothundr3) → Martin Pitt (pitti)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers