Application thread crash shows application crash error alert

Bug #1033902 reported by Matthew Paul Thomas
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Apport
Fix Released
High
Evan
apport (Ubuntu)
Fix Released
Medium
Evan

Bug Description

[IMPACT]

When an application thread crashes, Apport shows an alert that says the entire application has crashed. <https://wiki.ubuntu.com/ErrorTracker#app-crash> The alert includes the option to relaunch the application, even though it is still running.

This is confusing. It also means Ubuntu 12.04 users are exposed to more error alerts than they should be, because there is no option to ignore similar errors in future. The alert that is supposed to appear instead <https://wiki.ubuntu.com/ErrorTracker#thread> includes a checkbox to ignore future thread crashes in that application version.

[TESTCASE]

[REGRESSION POTENTIAL]

Related branches

tags: added: classification
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Evan (ev)
tags: added: whoopsie-daisy
tags: added: precise quantal
Evan (ev)
Changed in apport (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → Medium
status: Confirmed → In Progress
Evan (ev)
Changed in apport:
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.6.3-0ubuntu1

---------------
apport (2.6.3-0ubuntu1) raring; urgency=low

  * New upstream release. Changes since our previous snapshot:
    - debian.py: Only reject reports with useless stack traces if the report
      actually has a stack trace at all.
    - debian.py: Fix UTF-8 string handling. Thanks Ritesh Raj Sarraf.
    - debian.py: Fix crash on broken "Package" fields, as generated by current
      Debian/Ubuntu dkms package.
    - data/apport: Call fsync when writing upstart crash reports.
    - report.py, add_gdb_info(): Handle libnih's assertion messages.
      (LP: #997359)
    - apport-gtk, apport-kde: Don't provide an option to restart a crashed
      application when the crash occurred in a thread (LP: #1033902).
    - apport-retrace: Disallow option -C without option -S. Thanks Kyle
      Nitzsche.
    - fileutils.py, mark_report_upload(): Refresh the .upload stamps if a
      previous version of the report was already uploaded, but another
      instance of the problem happened since then. Thanks Brian Murray. (LP:
      #1084296)
    - Ignore implausibly low addresses when computing
      StacktraceAddressSignature. These are usually artifacts from gdb when
      not having debug symbols, and having too many of them prevents proper
      client-side duplicate detection and proper bucketing in daisy.
      (LP: #1084996)
    - fileutils.py: Ignore .desktop files with NoDisplay=true. (LP: #1048524)
  * debian/tests/control: Run tests as root, just like before switching our
    autopkgtests to run as user "ubuntu" by default. This enables a couple of
    extra tests, and avoids some confusion because the distro and the user
    name are identical.
  * data/package-hooks/source_linux-nexus7.py: Fix PEP-8 error.
 -- Martin Pitt <email address hidden> Fri, 30 Nov 2012 18:00:01 +0100

Changed in apport (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti)
Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers