apport errored when filing bug on test image alpha3

Bug #1028984 reported by Jim Sublette on 2012-07-25
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

oot@kubuntu:~# ubuntu-bug ubiquity
Traceback (most recent call last):
  File "/usr/share/apport/apport-kde", line 519, in <module>
    sys.exit(UserInterface.run_argv())
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 632, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 434, in run_report_bug
    self.collect_info(symptom_script)
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 943, in collect_info
    hookui.process_event()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 1488, in process_event
    self._response = getattr(self.ui, self._request_fn)(*self._request_args)
  File "/usr/share/apport/apport-kde", line 424, in ui_question_yesno
    response = KMessageBox.questionYesNoCancel(None, _(text), QString(),
NameError: global name 'QString' is not defined
^CException KeyboardInterrupt: KeyboardInterrupt() in <module 'threading' from '/usr/lib/python3.2/threading.py'> ignored

Jonathan Riddell (jr) on 2012-07-25
Changed in apport (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Changed in apport (Ubuntu Quantal):
importance: Undecided → High
Jonathan Riddell (jr) wrote :

Seems to be a problem in PyQt when using python 3
 from PyQt4.QtCore import QString
fails

affects: apport (Ubuntu Quantal) → python-qt4 (Ubuntu Quantal)
Jonathan Thomas (echidnaman) wrote :

The PyQt bindings for python3 have dropped the QString class in favor of the native unicode string type introduced in python 3. The KDE apport frontend will need to be ported to the new python3 native string API.

Changed in python-qt4 (Ubuntu Quantal):
status: Confirmed → Triaged
affects: python-qt4 (Ubuntu Quantal) → apport (Ubuntu Quantal)
Martin Pitt (pitti) wrote :
Changed in apport (Ubuntu Quantal):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.5.1-0ubuntu7

---------------
apport (2.5.1-0ubuntu7) quantal-proposed; urgency=low

  * bin/apport-bug: Explicitly set the PATH to that of ENV_SUPATH in
    /etc/login.defs and unset ENV and CDPATH. We need do this so that confined
    applications using ubuntu-browsers.d/ubuntu-integration cannot abuse the
    environment to escape AppArmor confinement via this script (LP: #1045986).
    This can be removed once AppArmor supports environment filtering
    (LP: 1045985)

apport (2.5.1-0ubuntu6) quantal; urgency=low

  * data/general/ubuntu.py: handle the case where a log file is compressed
    when reviewing package installation failures (LP: #917903)

apport (2.5.1-0ubuntu5) quantal; urgency=low

  * Use Python string rather than QString, LP: #1028984
 -- Jamie Strandboge <email address hidden> Wed, 05 Sep 2012 08:38:23 -0500

Changed in apport (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers