apport-gtk speaker test message refers to "Close" button as "OK"

Bug #678371 reported by Eliah Kagan on 2010-11-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport-symptoms (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: apport

While reporting https://bugs.launchpad.net/ubuntu/+source/apport/+bug/678360, I noticed that Apport says "Press OK to hear the test tone" but the button actually says "Close."

While this issue is rather minor, I think it could be confusing to novices, who may erroneously assume that the Close button quits Apport altogether and that they have done something wrong, causing no "OK" button to appear.

This is with version 1.14.1-0ubuntu8 of apport (same version for apport-gtk) on a 64-bit maverick system.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: apport-gtk 1.14.1-0ubuntu8
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
ApportLog:

Architecture: amd64
Date: Sun Nov 21 21:24:40 2010
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.utf8
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: apport

Related branches

I am removing the duplicate note on this report as the bug this was pointing at had mentioned two separate issues. This bug will be utilized to track the issue noted above where the user is prompted to 'Press OK to hear the test tone' and the only button available is 'Close'.

Steps to reproduce the issue:

1. Run ubuntu-bug from a shell window with no arguments

2. @ 'What kind of problem do you want to report?', respond with 'Sound/audio related problems'

3. @ 'What particular problem do you observe?', respond with 'Playback does not work, or is crackling'

4. @ 'Have you checked that your sound system is plugged in, and turned on?', respond with 'Yes'

5. @ 'What is the name of the sound card you are having problems with?', respond with 'HDA-Intel - HDA Intel'

6. Note the message "Press OK to hear the test tone", and the only option is "Close"

Changed in apport (Ubuntu):
status: New → Confirmed
Philip Muškovac (yofel) wrote :

Marking Triaged on AbuDawuds request.

Changed in apport (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

Currently working on a proposed fix.

affects: apport (Ubuntu) → apport-symptoms (Ubuntu)
Changed in apport-symptoms (Ubuntu):
assignee: nobody → AbuDawud (abudawud0)
status: Triaged → In Progress

I looked at the proposed branch, and its extremely messy, has conflicts, and looks like unintentional changes. Its unreviewable and unmergable in its current state :-/. I recommend checking out the head of the current branch (lp:~ubuntu-dev/apport/apport-symptoms), unbinding it, applying your changes locally, then re-pushing to launchpad.

Second branch looks sane, and the code changes seem to be correct (I can't currently test with apport easily on my current machine). I'm unsure if this is the proper way to fix the UI confusion, so I'll leave that to the apport developers to figure out.

Marking the branch reviewed; pitti, can you put in your two cents on this?

Paul Tagliamonte (paultag) wrote :

Switching to Triaged, by request of AbuDawud via IRC.

Changed in apport-symptoms (Ubuntu):
status: In Progress → Triaged
Changed in apport-symptoms (Ubuntu):
assignee: AbuDawud (abudawud0) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport-symptoms - 0.10

---------------
apport-symptoms (0.10) natty; urgency=low

  * audio.py: Resolves syntax confusion in audio test (LP: #678371)
 -- Weston Miller <email address hidden> Tue, 23 Nov 2010 09:45:08 +0100

Changed in apport-symptoms (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers