All Qt5 applications' menu bar is missing at non-Unity DEs after appmenu-qt5 installed

Bug #1307619 reported by Huck-bernhard on 2014-04-14
208
This bug affects 41 people
Affects Status Importance Assigned to Milestone
LyX
New
Undecided
Unassigned
appmenu-qt5
Undecided
Unassigned
appmenu-qt5 (Ubuntu)
High
Unassigned

Bug Description

1. Open "Qt Creator" Version 3.0.1 at the Gnome3 Desktop
2. Menu bar is missing.

------------ workaround ----------------------------------
After Deinstall appmenu-qt5 is the Menu bar working again.
Open Terminal:
sudo apt-get remove appmenu-qt5

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: appmenu-qt5 0.3.0+14.04.20140314-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic i686
ApportVersion: 2.14.1-0ubuntu2
Architecture: i386
CurrentDesktop: GNOME
Date: Mon Apr 14 18:52:18 2014
InstallationDate: Installed on 2014-02-14 (58 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140214)
SourcePackage: appmenu-qt5
UpgradeStatus: No upgrade log present (probably fresh install)

Huck-bernhard (huck-bernhard) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt5 (Ubuntu):
status: New → Confirmed

This bug also affects me. I'm running on Ubuntu 14.04 LTS and GNOME Shell 3.10. Tested with no gnome extensions and default configuration (dconf reset).

mcallegari (massimocallegari) wrote :

I confirm this too. I am using Ubuntu 14.04 and KDE 4.13.0.
Qt Creator version 3.0.1 installed via software center

description: updated
description: updated
summary: - Qt Creator Menu bar is missing at Gnome3 Desktop
+ Qt Creator Menu bar is missing at Gnome3 or KDE Desktop

I confirm this and removing appmenu-qt5 solve this bug.

I see this in Qt Creator as well as in a self-compiled LyX on Ubuntu 14.04. It might be useful to note that in the LyX case, one can get the menu bar back by executing the following command (in LyX's internal language)
ui-toggle menubar
Removing appmenu-qt5 solved the problem in both cases for me.

Jan Dorniak (jaskij) wrote :

The problem exists in i3 WM as well, the workaround is still the same (removing appmenu-qt5).

Ville Ranki (ville-ranki) wrote :

Happens also on Siilihai-client - i believe this affects all Qt Widget apps that use a menu. Workaround works.

pvdeynse (vandeynse) wrote :

a better (less drastic) workaround is to unset the environment variable QT_QPA_PLATFORMTHEME, this variable is set to:
     QT_QPA_PLATFORMTHEME=appmenu-qt5

the following will bring back the missing menu bar
     export QT_QPA_PLATFORMTHEME=

Changed in appmenu-qt5 (Ubuntu):
importance: Undecided → High
NoOp (glgxg) wrote :

Re comment #9: didn't work for me w/Scribus 1.50SVN Trunk:

$ env | grep QT
QT_IM_MODULE=ibus
QT_QPA_PLATFORMTHEME=
QT4_IM_MODULE=ibus

$ sudo apt-get remove appmenu-qt5

does work. However I wonder what affect it might have on indicator-appmenu:

$ apt-cache rdepends appmenu-qt5
appmenu-qt5
Reverse Depends:
  appmenu-qt5:i386
  indicator-appmenu

Eric (ericvmelo) wrote :

Also have this problem, using XMonad and Ubuntu 14.04.

Removing appmenu-qt5 solved the problem.

Also had the problem, Ubuntu SDK in Ubuntu 14.04.

Removing appmenu-qt5 solved the problem.

achevrier (a-chevrier-pro) wrote :

Also have the problem with openscad under ubuntu 14.04 + gnome-shell: menu bar of openscad is missing.
OpenScad uses Qt for user interface.

victor00000 (vict1971) wrote :

opa :D

Joseph (josephmirabel) wrote :

Also had the problem, using Gnome 3 and Ubuntu 14.04.

Removing appmenu-qt5 solved the problem.

Rohit Chhetri (rohit-chhetri) wrote :

I installed qt creator but I am missing text on the menu bar. I did remove appmenu-qt5. Still same problem.

please see attachment.

There is no text on menu. However if you click its work on function but text label are not displayed.

Thank you
Rohit

Huck-bernhard (huck-bernhard) wrote :

Hello Rohit,

can you send us more information.

Ubuntu Version ?
Qt Creator Version ?
Architecture?
if VirtualBox Gust settings ?
or Graphics card?

Rik Shaw (rik-shaw) wrote :

Using Gnome-Shell 3.16 in Ubuntu 15.10, I can confirm that removing appmenu-qt5 is the only way to get the vlc tray icon to show. You can confirm the problem by attempting to start vlc in the tray:

vlc --qt-start-minimized

With appmenu-qt5 installed, the following error is generated, and the vlc tray icon will NOT show (not even in the "drawer" at the bottom or by using "top icons" extension):

qt4 interface error: cannot start minimized without system tray bar

After removing appmenu-qt5 then vlc will be able to start properly with the above command (or starting normally will add the icon to the bottom 'legacy icon drawer' or to the panel using the "top icons" extension).

So, what is lost by removing appmenu-qt5? Is unity affected? I am hoping to not cause a problem for a system with both Unity and Gnome-Shell installed.

Rik Shaw (rik-shaw) wrote :

I created a separate report for the appmenu-qt5 bug that prevents vlc from showing in the gnome-shell drawer or panel: https://bugs.launchpad.net/ubuntu/+source/appmenu-qt5/+bug/1514147

Changed in appmenu-qt5 (Ubuntu):
assignee: nobody → Sushmita (sush-patil-mita)
Changed in appmenu-qt5 (Ubuntu):
assignee: Sushmita (sush-patil-mita) → nobody
V字龍(Vdragon) (vdragon) wrote :

Hi, I changed the bug title because it affect other Qt5 application(ReText) in order to duplicate Bug #1521176 .

summary: - Qt Creator Menu bar is missing at Gnome3 or KDE Desktop
+ All Qt5 applications' menu bar is missing at non-Unity DEs after
+ appmenu-qt5 installed
achevrier (a-chevrier-pro) wrote :

Hi. This bug of absence of menu bar affects also the usage of OPENSCAD when used under ubuntu 14-04 and gnome-shell.
OPENSCAD menu bar is accessible under Ubuntu14-04 UNITY (or METACITY ...) with appmenu-qt5 installed.
But, under gnome-shell+Ubuntu14-04, with appmenu-qt5 installed, the menu bar is not accessible (no menu bar at all).
However, under gnome-shell+ubuntu14-04, uninstalling appmenu-qt5 allows to access to the menu of OPENSCAD. The menu bar is present. However, the behaviour to acess to sub-items of menu bar, works in 2 steps: 1/ clic one time on the item menu does not show the subitem; 2/ reclic again on the same menu item allows to get the subitems.
And, with appmenu-qt5 uninstalled under Ubuntu14-04 UNITY, the menu bar is still visible and accessible, but its behaviour to access to sub-items is also changed (in 2 clic instead of 1 clic).

Want Privacy (lundril-p) wrote :

It seems there is actually a simple fix for most of these problems.
As far as I can tell the root cause of the problem is as follows:

The appmenu-qt5 package somehow grabs all the menus from all applications and sends them via D-Bus to the window manager. Of course this will only work if the window manager is actually listening for these kind of messages on D-Bus.

The appmenu-qt5 plugin will only do this, if according to the documentation the environment variable QT_QPA_PLATFORMTHEME is set to appmenu-qt5.

Now installing the appmenu-qt5 package will put a script under "/etc/profile.d/appmenu-qt5.sh" and this script is a single liner:
  export QT_QPA_PLATFORMTHEME=appmenu-qt5

So the environment variable is UNCONDITIONALLY set. I think this is just plain wrong, since the assumption that ALL window managers will support this undocumented D-Bus menu forwarding mechanism is rather weird.
I think the script "/etc/profile.d/appmenu-qt5.sh" should check if Unity is running and ONLY THEN set the environment variable.
For example something like this:

  if [ "$DESKTOP_SESSION" = "ubuntu" ]; then
    export QT_QPA_PLATFORMTHEME=appmenu-qt5
  fi

Note: I am not an Ubuntu wizard, so I am not sure what the best way is how to check for Unity in a bash script. I at least think the above would work...

Dmitry Shachnev (mitya57) wrote :

The plan is to get rid of appmenu-qt5 soon, see bug 1612767 where this is tracked.

I have this problem even *without* `appmenu-qt5` installed. I did have `appmenu-qt` installed, but removing it did *not* fix the problem. I'm using MATE on Ubuntu 16.10.

I DID, however, fix this by uninstalling Unity. I could't say which specific package, unfortunately, as I just picked large swathes of them.

I never liked Unity anyway.

David Gottlieb (plimsoll) wrote :

It's a desktop setting. Go into settings/appearance/behavior and check the options forshow the menu in the window's title bar and for always show menus. This fixed it for me - all my apps - QtCreator included - now behave correctly.

thieuquangtuan (rjchard.thieu) wrote :

I have the same problem on Ubuntu Mate 16.10
The menu bar, left toolbar,... are missing when i launch Qt Creator 4.2.1
I have tried "sudo apt remove appmenu-qt5" but it didn't work.

James (inisheer) wrote :

Fresh installation of Ubuntu 16.04LTS (Unity) and QT Creator v5.8.

The UI menu appears when opening a project which defaults to source code edit. The menu disappears when shifting to UI layout / designer. Returning to source code edit, the menu fails to reappear. I have tried the "workaround", which does not work... around..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers