Menu in the global title bar is missing after a window child in Qt5 applications

Bug #1302084 reported by Huck-bernhard on 2014-04-03
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
New
Undecided
Unassigned
Unity
Invalid
Undecided
Unassigned
appmenu-qt5
Critical
Łukasz Zemczak
appmenu-qt5 (Ubuntu)
Critical
Łukasz Zemczak

Bug Description

steps to get this behavior

1. "Settings | Appearance | Behavior" set Show the menus for a window in the window's title bar
2. Open qtcreator in Normal Window Size (not maximized) .
3. Move Mouse to the Title Bar, Menu Bar is showing. Open Menu "Open Help | About QtCreator..."
4. Close Window "About Qt Creator".
5. Move Mouse to the Title Bar, no menu bar is showing.

this behavior is also in different QT4 and QT5 Applicaion showing.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: appmenu-qt5 0.3.0+14.04.20140314-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
Uname: Linux 3.13.0-8-generic i686
ApportVersion: 2.14-0ubuntu1
Architecture: i386
Date: Thu Apr 3 19:38:03 2014
InstallationDate: Installed on 2014-02-14 (47 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140214)
SourcePackage: appmenu-qt5
UpgradeStatus: No upgrade log present (probably fresh install)

Huck-bernhard (huck-bernhard) wrote :
Łukasz Zemczak (sil2100) wrote :

Thank you for reporting the issue! I will be looking into it shortly.

Changed in appmenu-qt5:
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in appmenu-qt5 (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt5 (Ubuntu):
status: New → Confirmed
Changed in appmenu-qt5:
status: New → Confirmed
Changed in appmenu-qt5 (Ubuntu):
importance: Undecided → Medium
Changed in appmenu-qt5:
importance: Undecided → Medium
Łukasz Zemczak (sil2100) wrote :

So, I had a look at the bug briefly. I can reproduce it easily - some first hand observations:
- this only happens with the menus are in the window title-bar - everything works correctly with the global menu
- once the modal window is opened and then closed, HUD works normally
- when using HUD in the broken state to open up any modal window (like the about one that caused the failure), the menu appears on the modal window instead

Some first thoughts based on those observations: first of all, I'm not sure if it's really a problem in appmenu-qt5. Since it seems that appmenu exports the menu correctly through DBus, making it accessible by unity7 and hud. The problem seems to be with parent identification. The application is still the parent of the menu, but not the correct window. I will check if all is correct from our appmenu's perspective.

Changed in appmenu-qt5 (Ubuntu):
status: Confirmed → In Progress
Changed in appmenu-qt5:
status: Confirmed → In Progress
importance: Medium → High
Changed in appmenu-qt5 (Ubuntu):
importance: Medium → High
Łukasz Zemczak (sil2100) wrote :

And something else - it seems that modeless dialogs also cause the problem.

summary: - Menu in title bar is missing after a modal window child
+ Menu in the global title bar is missing after a window child
Changed in appmenu-qt5:
importance: High → Critical
Changed in appmenu-qt5 (Ubuntu):
importance: High → Critical
Łukasz Zemczak (sil2100) wrote :

Ok, so... all seems to look ok from the side of appmenu-qt5 here. I will be looking more on Monday, but I have also added unity as a possible culprit since there is some probability it's not appmenu-qt5 fault. Trevisan is not around today, so we'll know more next week. Bumped the bug to critical as basically opening ANY dialogish window in the application with LIM enabled causes the menu to malfunction. And this is a serious issue.

summary: - Menu in the global title bar is missing after a window child
+ Menu in the global title bar is missing after a window child in Qt5
+ applications
Changed in unity:
status: New → Invalid
Changed in appmenu-qt5:
status: In Progress → Invalid
Changed in appmenu-qt5 (Ubuntu):
status: In Progress → Invalid
Łukasz Zemczak (sil2100) wrote :

So, sorry for meddling with the projects here, but Trevinho first thought it's an old indicator-appmenu issue, but we see it still might be related to appmenu-qt5. LIM is not prepared for us still exporting a menu when the child window is opened. Not sure if we can fix this from our side - we might need a tweak in indicator-appmenu...

Changed in appmenu-qt5:
status: Invalid → In Progress
Changed in appmenu-qt5 (Ubuntu):
status: Invalid → In Progress

I would like to keep this around, since the fact that appmenu-qt should not export the menus on child windows is something that should be fixed anyway.

Marco if I understand your comment above correctly then the newest Unity in Vivid resloves this problem.

https://launchpad.net/ubuntu/+source/unity/7.3.1+15.04.20150219.2-0ubuntu1

There are no LIM menus on child windows of Qt apps and the Bug #1312137 was resolved by previous Unity upload in Vivid.

Benjamin Xiao (ben-r-xiao) wrote :

HI Mateusz, I haven't seen this problem on Vivid or Trusty for a really long time. We can probably mark this as fixed?

Łukasz Zemczak (sil2100) wrote :

Can anyone try to reproduce this issue indeed? Would be good to know if it got fixed with the past changes in the distribution.

B. Clausius (barcc) wrote :

This bug is fixed in Vivid. Menus available after child window closed, no menus in child window.

Changed in appmenu-qt5 (Ubuntu):
status: In Progress → Confirmed
Changed in appmenu-qt5:
status: In Progress → Triaged
Changed in appmenu-qt5 (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers