appmenu crashes on AppMenuPlatformMenuBar::setAltPressed

Bug #877791 reported by Steffen Röcker on 2011-10-18
100
This bug affects 22 people
Affects Status Importance Assigned to Milestone
appmenu-qt
Fix Released
Medium
Aurélien Gâteau
appmenu-qt (Ubuntu)
Medium
Aurélien Gâteau
Oneiric
Undecided
Unassigned

Bug Description

---- SRU info ----
[Impact]

Any Qt application whose main window does not have a menubar will crash when Alt is pressed.

[Development Fix]
Fixed in appmenu-qt by ensuring the code responsible for registering the mainwindow on DBus does not tell it has registered one when it did not.

[Stable Fix]
The fix proposed by Steffen is fine for Oneiric. Turned it into a debdiff (see attached patch)

[Test Case]
- Start fbreader
- Press Alt => application crashes

[Regression Potential]
No regression expected.

---- Original description ----
Several applications (calibre,fbreader) crash in AppMenuPlatformMenuBar::setAltPressed
because m_exporter is NULL.
Workaround in line 216:
- if (m_adapter) {
+ if (m_adapter && m_adapter->m_exporter) {
seems to work.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: appmenu-qt 0.2.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Wed Oct 19 00:40:29 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: appmenu-qt
UpgradeStatus: Upgraded to oneiric on 2011-08-07 (72 days ago)

Steffen Röcker (sroecker) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt (Ubuntu):
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Set to medium since the dupes were.

Changed in appmenu-qt (Ubuntu):
importance: Undecided → Medium
tags: added: patch
Changed in appmenu-qt (Ubuntu):
assignee: nobody → Aurélien Gâteau (agateau)
Aurélien Gâteau (agateau) wrote :

I just committed a slightly different fix. I am going to file an SRU for it.

Changed in appmenu-qt (Ubuntu):
status: Confirmed → Fix Committed
Aurélien Gâteau (agateau) wrote :

Just released a new tarball with the fix. Adjusted the Status: the fix has not been committed to the package yet.

Changed in appmenu-qt:
assignee: nobody → Aurélien Gâteau (agateau)
status: New → Fix Released
importance: Undecided → Medium
Changed in appmenu-qt (Ubuntu):
status: Fix Committed → Triaged
Aurélien Gâteau (agateau) wrote :

Attached a debdiff updating the package from 0.2.2 to 0.2.3.

description: updated
Aurélien Gâteau (agateau) wrote :

Please ignore this debdiff, it's broken. Will provide a fixed one today.

Aurélien Gâteau (agateau) wrote :

I intend to write a proper fix in appmenu-qt itself, but Steffen patch works fine and is not as intrusive as what I have in mind, so I included it in a new version of the 0.2.2 package. See attached debdiff.

Aurélien Gâteau (agateau) wrote :

Fixed changelog to use oneiric-proposed instead of oneiric

Changed in appmenu-qt:
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt (Ubuntu Oneiric):
status: New → Confirmed
summary: - appmenu crashes on AppMenuPlatformMenuBar::setAltPressed
+ appm
summary: - appm
+ appmenu crashes on AppMenuPlatformMenuBar::setAltPressed
Changed in appmenu-qt:
status: In Progress → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-qt - 0.2.2-0ubuntu2

---------------
appmenu-qt (0.2.2-0ubuntu2) precise; urgency=low

  * debian/patches/kubuntu_02_dont_crash_when_alt_is_pressed.diff:
    - fix crash when pressing alt in an application whose main window does not
      have a menubar (LP: #877791)
 -- Aurelien Gateau <email address hidden> Thu, 20 Oct 2011 15:19:52 +0200

Changed in appmenu-qt (Ubuntu):
status: Triaged → Fix Released

Hello Steffen, or anyone else affected,

Accepted appmenu-qt into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in appmenu-qt (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Works fine here, fbreader & calibre, creates no new issues

Martin Pitt (pitti) on 2011-11-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-qt - 0.2.2-0ubuntu1.1

---------------
appmenu-qt (0.2.2-0ubuntu1.1) oneiric-proposed; urgency=low

  * debian/patches/kubuntu_02_dont_crash_when_alt_is_pressed.diff:
    - fix crash when pressing alt in an application whose main window does not
      have a menubar (LP: #877791)
 -- Aurelien Gateau <email address hidden> Thu, 20 Oct 2011 15:19:52 +0200

Changed in appmenu-qt (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers