Global menu disappearing on KDE Apps that minimize to tray

Bug #775278 reported by Leonardo Torok on 2011-05-02
252
This bug affects 64 people
Affects Status Importance Assigned to Milestone
appmenu-qt
Fix Released
Undecided
Aurélien Gâteau
appmenu-qt (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

It happens with KDE apps running on Ubuntu 11.04 (Unity 3D). If I start Amarok (or Ktorrent) and closes the app (minimizing it to the tray) and opens it again (using the tray menu), the global menu does't appears anymore. It's necessary to restart the app to fix it. Sometimes, it's necessary to minimize/restore the apps more than one time to reproduce the problem, but it surely occurs.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,mousepoll,resize,zoom,water,place,screenshot,shift,imgpng,grid,vpswitch,regex,firepaint,move,wall,session,mag,animation,wobbly,expo,unitymtgrabhandles,workarounds,ezoom,animationaddon,staticswitcher,fade,scale,unityshell]
Date: Sun May 1 22:53:53 2011
ProcEnviron:
 LANGUAGE=pt_BR:en
 PATH=(custom, user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-05-01 (0 days ago)

Related branches

Leonardo Torok (leotorok) wrote :
Paweł Bara (keirangtp) wrote :

I can confirm this behaviour with the Clementine application. This happens to me often and I'm also pretty sure that minimizing to tray has something to do with this.

truant (launchpad-ninj4) wrote :

Getting this with ktorrent.

Paweł Bara (keirangtp) wrote :

This is really annoying because if app closes and minimizes to tray then usually the only "normal" possibility to really close it is by using it's menu ("File / Close" for example).

That leads to a conclusion -> if global menu disappears for such an application, the only way to close it is by killing the process.

Benjamin (benjamin-schaefer) wrote :

Can confirm this with Akregator.

Florian Boucault (fboucault) wrote :

This bug does not seem to happen in Unity 2D.

Changed in unity-2d:
status: New → Invalid
Bennett Kanuka (bkanuka) wrote :

Regarding Clemintine

Bennett Kanuka (bkanuka) wrote :

Oops - I don't know how that happened. As I was saying...

Regarding Clementine, as soon as you open the program go to Preferences -> Behavior -> Uncheck "Show tray icon". This seems to fix the problem for now.

I think whats happening is when we close the window it's closing to a hidden tray icon, then reshowing the window using the sound menu (unity) is only reshowing the window, not restoring the entire application. As far as Qt is concerned, the application is still closed. Thus the menu isn't regenerated - it's not part of the window. Just a hypothesis though :)

Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in bamf:
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity-2d:
status: Invalid → Confirmed
Changed in unity-2d:
status: Confirmed → Invalid
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: Invalid → Confirmed
Changed in unity-2d:
status: Confirmed → Invalid
Conscious User (conscioususer) wrote :

I think this might not be exclusive to KDE apps. I'm experiencing Bug #775080, which is very similar but with Thunderbird.

Shahed Faisal (mushaf) on 2011-11-07
Changed in clementine:
status: New → Confirmed
Zordid (zordid-gmx) wrote :

Annoying! Fix it - PLEASE!!!!! Half a year should be enough time to release a fix!

Leonardo Torok (leotorok) wrote :

This bug still occcurs on Oneiric. Won't get fixed?

JC (nothingness) wrote :

I had no problem with Clementine until version 1.0
The global menu fails to detect it with or without the system tray icon enabled.

JC (nothingness) wrote :

Nevermind about Clementine ^ That was by design :(

flying sheep (flying-sheep) wrote :

@shadydogg2731

No, indeed DO mind especially Clementine: they disabled the global menu because of this very bug.

It will be immediately reenabled once this is finally fixed. No pressure, though ;)

What really annoy me in this bug is: Almost 9 months and NO ONE FROM UNITY said a line about this. I dont think Qt applications breaking in appmenu is a thing to just leave.

Omer Akram (om26er) wrote :

same as bug 667050 ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-qt (Ubuntu):
status: New → Confirmed
Conscious User (conscioususer) wrote :

@Omer:

No, as far as I know this bug can happen without #667050 happening.

no longer affects: bamf
no longer affects: unity-2d
no longer affects: bamf (Ubuntu)
no longer affects: unity (Ubuntu)
Changed in appmenu-qt:
status: New → Fix Committed
assignee: nobody → Aurélien Gâteau (agateau)
Aurélien Gâteau (agateau) wrote :

Committed a fix for this. An updated Precise package should be available here soon:
https://launchpad.net/~agateau/+archive/appmenu-qt

I do not expect any regression, but more testers are welcome.

There will be an update to fix this issue on Oneiric too?

Em 07-02-2012 11:26, Aurélien Gâteau escreveu:
> Committed a fix for this. An updated Precise package should be available here soon:
> https://launchpad.net/~agateau/+archive/appmenu-qt
>
> I do not expect any regression, but more testers are welcome.
>

Aurélien Gâteau (agateau) wrote :

There is now an Oneiric package in https://launchpad.net/~agateau/+archive/appmenu-qt for you to try.

Leonardo Torok (leotorok) wrote :

I've added this PPA and updated the appmenu-qt package. After several
tests, it wasn't possible to reproduce the bug with Amarok or Ktorrent,
so it seems that it's fixed now.

Em 08-02-2012 06:59, Aurélien Gâteau escreveu:
> There is now an Oneiric package in
> https://launchpad.net/~agateau/+archive/appmenu-qt for you to try.
>

Thanks very much for fixing this! I can confirm the fix works in Clementine on Oneiric, so I've removed the hack that disabled the global menubar: http://code.google.com/p/clementine-player/source/detail?r=62d5c8224bcc

Sebastien Bacher (seb128) wrote :

Seems like the issue should be fixed with the precise version by looking at the vcs it was fixed in 0.2.5 and precise has 0.2.6

Changed in unity:
status: Confirmed → Invalid
importance: Undecided → Low
Changed in appmenu-qt (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Changed in appmenu-qt:
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-05-20
affects: clementine → clementine (Ubuntu)
affects: unity → unity (Ubuntu)
no longer affects: clementine (Ubuntu)
no longer affects: unity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers