Doesn't work with applications started from a saved session

Bug #602913 reported by Scott Kitterman on 2010-07-07
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
appmenu-qt (Ubuntu)
High
Aurélien Gâteau

Bug Description

Binary package hint: plasma-widget-menubar

Konsole still has it's normal menu and the appmenu widget says "no items".

This instance of Konsole had been autostarted from a saved session. If I exit Konsole and restart, then it works. I can replicate the same problem with other applications.

Related branches

Changed in plasma-widget-menubar (Ubuntu):
importance: Undecided → Medium
Scott Kitterman (kitterman) wrote :

Bumping the importance since this can affect every application.

summary: - Doesn't work with Konsole
+ Doesn't work with applications started from a saved session
description: updated
Changed in plasma-widget-menubar (Ubuntu):
importance: Medium → High
Scott Kitterman (kitterman) wrote :

This seems a bit different after last night's updates. The menus are stripped from autostart applications, but not available in the menubar.

I tried this with Konsole. It had neither the application menu nor items available in the menubar on start. Then I started a second instance of Konsole (which, as expected, was fine). If I quit the second instance, the menu items were available from the appmenu in the first one.

Scott Kitterman (kitterman) wrote :

This may be just a timing issue. I'm seeing this problem in some cases and not others now (it happened every time before last night's updates).

Changed in plasma-widget-menubar (Ubuntu):
assignee: nobody → Aurélien Gâteau (agateau)
Aurélien Gâteau (agateau) wrote :

Will activate session restoration to test it there.

Aurélien Gâteau (agateau) wrote :

I just gave it a try and I can't reproduce it anymore, neither with plasma-desktop nor plasma-netbook. Is it still happening for you?

Yes. I can still replicate it.

It doesn't happen every time, but logging out with konsole open and then
logging back in did it for me.

If I then exit konsole and start it again, it's correct.

Didier Roche (didrocks) on 2011-09-05
affects: plasma-widget-menubar (Ubuntu) → appmenu-qt (Ubuntu)
Changed in appmenu-qt (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-qt - 0.2.2-0ubuntu1

---------------
appmenu-qt (0.2.2-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Update "Status" dbusmenu property, making it possible to show menubar
      in Unity panel by pressing Alt (LP: #737419).
    - Improve robustness: menubar gets correctly exposed and unexposed when
      menubar renderer is started or stopped (LP: #838115, #602913).
    - Change licence to LGPLv3.
  * debian/copyright:
    - update for new licence
  * debian/control:
    - dep on libdbusmenu-qt-dev 0.9.0
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Fri, 02 Sep 2011 13:32:01 +0200

Changed in appmenu-qt (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers