gnome-display-properties crashed with SIGSEGV in g_object_set()

Bug #729065 reported by Eliah Kagan on 2011-03-04
70
This bug affects 8 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Fix Released
Undecided
Unassigned
appmenu-gtk (Ubuntu)
High
Michael Terry
Natty
High
Michael Terry

Bug Description

Binary package hint: gnome-control-center

While running from today's daily live (i.e. desktop) natty CD (md5sum 5f1c4376fb3c42742627d9f77e83547e), with gnome-control-center 1:2.32.1-0ubuntu5, I opened System > Preferences > Monitors (i.e. gnome-display-properties) and successfully changed the resolution from 1024x768 to 800x600, since I am using the live CD to install Natty on a virtual machine, and I wanted the virtual machine's "screen" to fit more comfortably on the host desktop.

After finding bug 729057 (which is a duplicate of bug 727905), I opened System > Preferences > Monitors again, with the intention of changing the screen resolution back to 1024x768 as a workaround. However, when I attempted to expand the drop-down menu of resolutions (by clicking on it), this crash occurred.

I was initially unable to reproduce this bug by re-entering gnome-display-properties; my subsequent attempt to change the resolution back to 1024x768 was successful. However, I have since attempted to change the resolution, sometimes with success, and sometimes without success (i.e. reproducing this crash, though on the same machine in the very same login session, running from the live CD).

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gnome-control-center 1:2.32.1-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Fri Mar 4 13:14:41 2011
ExecutablePath: /usr/bin/gnome-display-properties
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110304)
ProcCmdline: gnome-display-properties
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xaecaa4 <g_object_set+36>: cmpl $0x50,(%eax)
 PC (0x00aecaa4) ok
 source "$0x50" ok
 destination "(%eax)" (0x00000028) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 g_object_set () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
 ?? () from /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
 g_simple_async_result_complete () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
Title: gnome-display-properties crashed with SIGSEGV in g_object_set()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (nautilus:4274): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Related branches

visibility: private → public
description: updated

StacktraceTop:
 g_object_set (_object=0x21178110, first_property_name=0xeba15b "show-local") at /build/buildd/glib2.0-2.28.1/./gobject/gobject.c:1816
 app_menu_bridge_set_show_local (bridge=0x21178110, local=0) at bridge.c:290
 register_application_window_cb (object=0x210d5598, res=0x2121aae8, user_data=0x211c8580) at bridge.c:329
 g_simple_async_result_complete (simple=0x2121aae8) at /build/buildd/glib2.0-2.28.1/./gio/gsimpleasyncresult.c:747
 reply_cb (connection=0x21113b98, res=0x2121ab20, user_data=0x2121aae8) at /build/buildd/glib2.0-2.28.1/./gio/gdbusproxy.c:2158

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
affects: gnome-control-center (Ubuntu) → indicator-appmenu (Ubuntu)
Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Michael Terry (mterry)
importance: Medium → Undecided
status: New → Confirmed
importance: Undecided → High

I have been able to reproduce the crash (even though it does not happen every time, and seems to happen less than half the time). Also, I have just realized that the crash occurs not when selecting a resolution from the drop-down menu, but rather than initially attempting to expand the drop-down menu (by clicking on it). I will edit the bug report's description to reflect these facts, but I wanted to document the change here (mainly for people who have already read the bug report).

description: updated
Michael Terry (mterry) wrote :

Eliah, I have not been able to reproduce, but I have a potential fix from inspecting the stacktrace. Would you be willing to try a fixed package I put in a PPA for me?

Yes, certainly. However, both times I was able to produce the crash were in the same session, and that when running off the daily live CD. Now that I've installed Natty, should I go ahead and try to reproduce this bug on the installed, and then install the package from your PPA *after* successfully reproducing it?

(As a related question: When the crash happened on the live CD, debug symbol packages were not installed. The "Apport retracing service" seems to have succeeded at generating a good trace in this case, but if I get a trace with the debug symbol package installed, should I submit that trace?)

Clarification: "...should I go ahead and try to reproduce this bug on the installed Natty system running the non-PPA packages, and then install the package from your PPA *after* successfully reproducing it?"

Michael Terry (mterry) wrote :

Don't worry about resubmitting a trace, apport does a good enough job.

Yeah, you should probably reproduce it in a real session to confirm it's not some weird difference with the live cd and then try the PPA. Thanks!

I successfully reproduced the original bug on the installed Natty system (which was running appmenu-gtk 0.1.95-0ubuntu1, which I presume is the same version that was running on the daily live CD system that I used to test and install Natty earlier today). So I then enabled your PPA and installed the PPA version of appmenu-gtk (0.1.95-0ubuntu1test2) and rebooted. Instead of the crash documented in this bug occurring, a new crash occurred instead, following the same pattern (i.e. I had try a number of times in order to produce a crash). That new crash was in invoke_get_all_properties_in_idle_cb() instead of g_object_set(). Like this crash, the new crash is also a segfault.

I don't know what the protocol is for conveying detailed crash data for crashes of experimental packages from unofficial PPA's in pursuit of a fix to an existing and reported bug in an official package. But I went ahead and let Apport report it, and I filled in the details and submitted the report on Launchpad. So the crash in appmenu-gtk 0.1.95-0ubuntu1test2 (from ppa:mterry/ppa) is reported as bug 729230, with apport-collected bug data and a thorough description.

Even besides the files attached by Apport, slightly more information is presented in bug 729230 than in this comment.

Michael Terry (mterry) wrote :

Interesting! OK, I will take a look. Thanks so much for your testing!

I'm glad to help in making Natty more stable (and quite pleased by your very rapid response after I initially reported this bug!). Please let me know if there's anything else I can do.

Changed in indicator-appmenu (Ubuntu Natty):
status: Confirmed → Fix Committed
Michael Terry (mterry) on 2011-03-09
Changed in indicator-appmenu:
status: New → Fix Committed
Ted Gould (ted) on 2011-03-10
affects: indicator-appmenu (Ubuntu Natty) → appmenu-gtk (Ubuntu Natty)
affects: indicator-appmenu → appmenu-gtk
Changed in appmenu-gtk:
status: Fix Committed → Fix Released
milestone: none → 0.1.96
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.96-0ubuntu1

---------------
appmenu-gtk (0.1.96-0ubuntu1) natty; urgency=low

  [ Ted Gould ]
  * New upstream release.
    ∘ Make the registration of application windows cancelable
      (LP: #729065)
    ∘ Check to make sure toplevel hasn't died (LP: #726388)
    ∘ Fix showing items so that they show when mnemonic is
      pressed (LP: #729203)

  [ Ken VanDine ]
  * debian/control
    - bumped build depends for dbusmenu to 0.3.101
 -- Ken VanDine <email address hidden> Thu, 10 Mar 2011 15:22:53 -0500

Changed in appmenu-gtk (Ubuntu Natty):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

This bugfix has had the effect of causing the appmenu in the unity panel not to show when focus is on the Desktop
ie. the File Edit View Places Help

Seen since the upgrade of appmenu-gtk (0.1.96-0ubuntu1) on several installs , also on a fresh install from 03/19 iso
A rebuild using rev 124 is fine, rev 125 kills that menu
noted here
bug #733050

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers