Pressing Add in the appearance properties crashes the applicaiton

Bug #625885 reported by Gord Allott
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
appmenu-gtk (Ubuntu)
Low
Canonical Desktop Experience Team
Maverick
Low
Canonical Desktop Experience Team

Bug Description

Binary package hint: gnome-control-center

Backtrace from application crash

0 0x0000007800000008 in ?? ()
#1 0x00007ffff4a99ccd in g_hash_table_lookup () from /lib/libglib-2.0.so.0
#2 0x00007fffed28166d in ?? ()
   from /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
#3 0x00007fffed281855 in ?? ()
   from /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
#4 0x00007ffff616747e in gtk_menu_shell_insert ()
   from /usr/lib/libgtk-x11-2.0.so.0
#5 0x00007ffff60b6734 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#6 0x00007ffff60b6e31 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#7 0x00007ffff51606ce in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#8 0x00007ffff5178f59 in ?? () from /usr/lib/libgobject-2.0.so.0
#9 0x00007ffff517a6d6 in g_signal_emit_valist ()
   from /usr/lib/libgobject-2.0.so.0
#10 0x00007ffff517af43 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#11 0x00007ffff6149b30 in gtk_list_store_insert ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0x00007ffff60b63fa in gtk_combo_box_append_text ()
   from /usr/lib/libgtk-x11-2.0.so.0
#13 0x00007ffff60f6966 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x000000000041333a in wp_create_filechooser ()
#15 0x0000000000413480 in ?? ()
#16 0x00007ffff51606ce in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-control-center 1:2.30.1-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Aug 28 16:39:10 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-control-center

Revision history for this message
Gord Allott (gordallott) wrote :
Revision history for this message
bbordwell (benbordwell) wrote :

Thank you for taking the time to help make Ubuntu better. Is the add button you are talking about the add button under the background tab? this is the only add button I could find and pressing it did not cause a crash for me.

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue is due to appmenu-gtk

affects: gnome-control-center (Ubuntu) → appmenu-gtk (Ubuntu)
Changed in appmenu-gtk (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
status: Incomplete → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue has been fixed in trunk now, the new version will be uploaded after beta this week

Changed in appmenu-gtk (Ubuntu Maverick):
status: New → Fix Committed
importance: Undecided → Low
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.7-0ubuntu2

---------------
appmenu-gtk (0.1.7-0ubuntu2) maverick; urgency=low

  * Backport trunk commit to fix crashers (lp: #624607, #625885, #628672)
 -- Sebastien Bacher <email address hidden> Tue, 31 Aug 2010 22:48:38 +0200

Changed in appmenu-gtk (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers