gnome-display-properties crashed with SIGFPE in g_hash_table_lookup()

Bug #624607 reported by gogo
78
This bug affects 15 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
Fix Released
High
Cody Russell
appmenu-gtk (Ubuntu)
Medium
Canonical Desktop Experience Team
Maverick
Medium
Canonical Desktop Experience Team

Bug Description

Binary package hint: gnome-control-center

gnome-display-properties crashed with SIGFPE in g_hash_table_lookup()

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-control-center 1:2.30.1-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.25-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
Date: Thu Aug 26 13:58:06 2010
ExecutablePath: /usr/bin/gnome-display-properties
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100803.1)
ProcCmdline: gnome-display-properties
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
Signal: 8
SourcePackage: gnome-control-center
StacktraceTop:
 g_hash_table_lookup () from /lib/libglib-2.0.so.0
 ?? ()
 ?? ()
 gtk_menu_shell_insert ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
Title: gnome-display-properties crashed with SIGFPE in g_hash_table_lookup()
UserGroups: adm admin cdrom dialout disk libvirtd lpadmin plugdev sambashare

Related branches

Revision history for this message
gogo (trebelnik-stefina) wrote :
visibility: private → public
Revision history for this message
joopbraak (joopbraak) wrote :

Can't open the System, Preferences, Monitors shortcut anymore, it just crashes.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is due to appmenu-gtk

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Revision history for this message
Matthias Urlichs (smurf) wrote :

Is there a workaround?

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Sebastien Bacher (seb128) wrote :

you could wokraround the crash by unsetting the UBUNTU_MENUPROXY variable or uninstall appmenu-gtk

affects: gnome-control-center (Ubuntu) → appmenu-gtk (Ubuntu)
Cody Russell (bratsche)
Changed in appmenu-gtk:
assignee: nobody → Cody Russell (bratsche)
importance: Undecided → High
status: New → In Progress
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue has been fixed in trunk now, thanks Cody for the work there!

Changed in appmenu-gtk (Ubuntu Maverick):
status: Confirmed → Fix Committed
Changed in appmenu-gtk:
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package appmenu-gtk - 0.1.7-0ubuntu2

---------------
appmenu-gtk (0.1.7-0ubuntu2) maverick; urgency=low

  * Backport trunk commit to fix crashers (lp: #624607, #625885, #628672)
 -- Sebastien Bacher <email address hidden> Tue, 31 Aug 2010 22:48:38 +0200

Changed in appmenu-gtk (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers