appmenu-gtk cannot be build with Glib > 2.30

Bug #1153707 reported by Roelof on 2013-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppMenu GTK+
New
Undecided
Unassigned
appmenu-gtk (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

When I want to build appmenu-gtk 6.20 It fails with this:

make[2]: Entering directory `/tmp/rmake/builds/appmenu-gtk/appmenu-gtk-12.10.2/s
rc'
make all-am
make[3]: Entering directory `/tmp/rmake/builds/appmenu-gtk/appmenu-gtk-12.10.2/s
rc'
  CC libappmenu_la-bridge.lo
In file included from /usr/include/gtk-2.0/gdk/gdkevents.h:37,
                 from /usr/include/gtk-2.0/gdk/gdkdisplay.h:32,
                 from /usr/include/gtk-2.0/gdk/gdkscreen.h:33,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:31,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from bridge.c:26:
/usr/include/gtk-2.0/gdk/gdkinput.h:133: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'gchar'
In file included from /usr/include/gtk-2.0/gdk/gdkscreen.h:33,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:31,
:

I think this has to do with depracted functions of glib 2.30 or higher.

Roelof

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers