apparmor_parser crashed with SIGSEGV in __libc_start_main()

Bug #626984 reported by John Lenton on 2010-08-30
112
This bug affects 17 people
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Medium
Jamie Strandboge
Lucid
Medium
Jamie Strandboge
Maverick
Medium
Jamie Strandboge
Natty
Medium
Jamie Strandboge

Bug Description

Binary package hint: apparmor

no idea what this one's about

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: apparmor 2.5.1~pre1393-0ubuntu5
ProcVersionSignature: Error: [Errno 2] No such file or directory: '/proc/version_signature'
Uname: Linux 2.6.36-020636rc2-generic i686
ApparmorStatusOutput:
 Error: command /usr/sbin/apparmor_status failed with exit code 4: You do not have enough privilege to read the profile set.
 apparmor module is loaded.
Architecture: i386
Date: Mon Aug 30 14:45:34 2010
ExecutablePath: /sbin/apparmor_parser
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100803.1)
ProcCmdline: BOOT_IMAGE=/boot/vmlinuz-2.6.36-020636rc2-generic root=UUID=175ea95e-219c-4d56-b154-1f91ac3572d4 ro crashkernel=384M-2G:64M,2G-:128M quiet
ProcEnviron: PATH=(custom, no user)
SegvAnalysis:
 Segfault happened at: 0x8051044: repnz scas %es:(%edi),%al
 PC (0x08051044) ok
 source "%es:(%edi)" (0x0000007b) not located in a known VMA region (needed readable region)!
 destination "%al" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: apparmor
StacktraceTop:
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
Title: apparmor_parser crashed with SIGSEGV in __libc_start_main()
UserGroups:

John Lenton (chipaca) wrote :

Stacktrace:
 #0 0x08051044 in main ()
 No symbol table info available.
StacktraceTop: main ()
ThreadStacktrace:
 .
 Thread 1 (process 21223):
 #0 0x08051044 in main ()
 No symbol table info available.

Changed in apparmor (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Kees Cook (kees) on 2010-09-14
visibility: private → public
Kees Cook (kees) on 2010-09-15
Changed in apparmor (Ubuntu):
status: New → Confirmed
Changed in apparmor (Ubuntu Maverick):
milestone: none → ubuntu-10.10
Kees Cook (kees) on 2010-09-15
Changed in apparmor (Ubuntu Maverick):
status: Confirmed → In Progress
Kees Cook (kees) on 2010-09-15
Changed in apparmor (Ubuntu Maverick):
assignee: nobody → Kees Cook (kees)
Jamie Strandboge (jdstrand) wrote :

Maverick is now frozen and as this bug doesn't affect default maverick users, I'm targeting this for maverick-updates.

Changed in apparmor (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
Changed in apparmor (Ubuntu Natty):
milestone: maverick-updates → none
Jamie Strandboge (jdstrand) wrote :

SRU

1. Impact of the bug is low for stable releases, unless the user is having a kernel issue and the kernel team asks the user to run an upstream kernel.

2. This has not been addressed in the development branch (it isn't open yet).

3. This is r1430 from the apparmor-2.5 branch, which is part of AppArmor 2.5.1. This patch is not included in the 2.5.1rc1 package in maverick, but the patch is quite small (see the linked branch). This patch will cause apparmor_parser to exit with error it can't find the /sys/kernel/security/apparmor/features file.

4. TEST CASE:
Run an upstream kernel, and try to use the parser. Eg:
$ sudo apparmor_parser -r -W -T /etc/apparmor.d/usr.sbin.cupsd

5. The regression potential of the patch is low, since Ubuntu releases have the compatibility patch (and therefore /sys/kernel/security/apparmor/features).

Changed in apparmor (Ubuntu Maverick):
assignee: Kees Cook (kees) → Jamie Strandboge (jdstrand)
Changed in apparmor (Ubuntu Natty):
status: In Progress → Triaged
assignee: Kees Cook (kees) → Jamie Strandboge (jdstrand)
Jamie Strandboge (jdstrand) wrote :

Uploaded 2.5.1-0ubuntu0.10.10.1 to maverick-proposed.

Changed in apparmor (Ubuntu Maverick):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Jamie Strandboge (jdstrand) wrote :

This was fixed in 2.5.1-0ubuntu1 on natty.

Changed in apparmor (Ubuntu Natty):
status: Triaged → Fix Released
Changed in apparmor (Ubuntu Lucid):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Jamie Strandboge (jdstrand)
milestone: none → lucid-updates
Jamie Strandboge (jdstrand) wrote :

Uploaded 2.5.1-0ubuntu0.10.04.1 to lucid-proposed.

Anders Aagaard (aagaande) wrote :

Can't find any apparmor related packages in maverick-proposed. And I've run into the bug. Am I missing something here?

Steve Langasek (vorlon) wrote :

The apparmor package that was uploaded to maverick-proposed fails to build, so no binary packages are available. You'll need to wait for a fixed package to be uploaded.

Changed in apparmor (Ubuntu Maverick):
status: In Progress → Won't Fix
Changed in apparmor (Ubuntu Lucid):
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers