In a PDF document, the mailto link does not work

Bug #590462 reported by Elbarbudo on 2010-06-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Low
Jamie Strandboge
Lucid
Low
Jamie Strandboge

Bug Description

SRU Justification

1. impact of the bug is low for stable releases, but the fix is non-intrusive. It is included here as part of the 2.5.1 update for Lucid (LP: #660077)

2. This has been addressed during the maverick development cycle.

3. Patch adjusts the path for thunderbird in abstractions/ubuntu-email

4. TEST CASE:
* $ sudo apt-get install thunderbird
* Configure thunderbird as the preferred mail reader in System/Preferences/Preferred Applications
* open the attached PDF in evince and click on the mailto link

5. The regression potential is very low for this patch as it only adds additional access to launch thunderbird.

Binary package hint: evince

I have Thunderbird as mail client.
Clicking a "mailto" link in Firefox opens correctly Thunderbird.

But in an pdf document opened by Evince, clicking a mailto link leads to the following error :
"L'exécution du processus fils « /usr/lib/thunderbird-3.0.4/thunderbird » a échoué (Permission non accordée)"

Strange because, I can see :

patrice@grosbill:~$ ls -l /usr/lib/thunderbird-3.0.4/thunderbird
-rwxr-xr-x 1 root root 3885 2010-04-23 14:37 /usr/lib/thunderbird-3.0.4/thunderbird
patrice@grosbill:~$

and I can run this command from a terminal.
I did not find any place to define the mail client in Evince.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: evince 2.30.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Jun 6 19:25:38 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427.1)
KernLog:

ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: evince

Related branches

Elbarbudo (patricearnal) wrote :
Elbarbudo (patricearnal) wrote :

HTTP links do work correctly.

Sebastien Bacher (seb128) wrote :

it seems apparmor is block the software

affects: evince (Ubuntu) → apparmor (Ubuntu)
Sebastien Bacher (seb128) wrote :

the issue is with the ubuntu-email abstraction list rather

Sebastien Bacher (seb128) wrote :

see /etc/apparmor.d/abstractions/ubuntu-email

Le 07/06/2010 11:03, Sebastien Bacher a écrit :
> see /etc/apparmor.d/abstractions/ubuntu-email
>
>
You are right : it works by adding the line

/usr/lib/thunderbird-3.0.4/thunderbird Ux,

in /etc/apparmor.d/abstractions/ubuntu-email a,d restarting apparmor

Thank you

Changed in apparmor (Ubuntu):
status: New → Triaged
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Low
Changed in apparmor (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.5.1~pre1393-0ubuntu1

---------------
apparmor (2.5.1~pre1393-0ubuntu1) maverick; urgency=low

  * Update to upstream bzr revision 1393 from lp:apparmor/2.5.
    * add dbus-session abstraction (LP: #566207)
    * require owner in user-tmp abstraction (LP: #578922)
    * don't use uninitialized $opt_s (LP: #582075)
    * allow thunderbird 3 in abstractions/ubuntu-email (LP: #590462)
    * allow gmplayer in abstractions/ubuntu-media-players (LP: #591421)
  * debian/control: updated branches.
  * debian/patches/0001-local-includes.patch: backported patch from trunk to
    allow local administrators to customize their profiles without modifying
    a shipped profile
  * debian/rules:
    - don't pass RELEASE to libapparmor's 'make install' as it breaks the
      build and isn't used by the Makfile anyway
    - install apparmor.d/local/README in apparmor, not apparmor-profiles
    - don't install apparmor.d/local/usr.sbin.ntpd
  * Drop the following patches already included upstream:
    - 0001-lp538561.patch
    - 0002-aalogprof-warnings.patch
    - 0003-fix-memleaks.patch
    - 0004-lp549557.patch
    - 0005-lp538661.patch
    - 0006-lp611248.patch
 -- Jamie Strandboge <email address hidden> Thu, 05 Aug 2010 16:10:46 -0500

Changed in apparmor (Ubuntu):
status: Fix Committed → Fix Released
Changed in apparmor (Ubuntu Lucid):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Low
milestone: none → lucid-updates
status: New → In Progress
Jamie Strandboge (jdstrand) wrote :
description: updated

Accepted apparmor into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in apparmor (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Jamie Strandboge (jdstrand) wrote :

Upgraded to 2.5.1-0ubuntu0.10.04.1 in lucid-proposed and this issue is resolved.

Martin Pitt (pitti) on 2010-12-14
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (10.1 KiB)

This bug was fixed in the package apparmor - 2.5.1-0ubuntu0.10.04.1

---------------
apparmor (2.5.1-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * Backport 2.5.1-0ubuntu0.10.10.1 from maverick for userspace tools to work
    with newer kernels (LP: #660077)
    NOTE: user-tmp now uses 'owner' match, so non-default profiles will have
    to be adjusted when 2 separately confined applications that both use the
    user-tmp abstraction depend on being able to cooperatively share files
    with each other in /tmp or /var/tmp.
  * remove the following patches (features not appropriate for SRU):
    - 0002-add-chromium-browser.patch
    - 0003-local-includes.patch
    - 0004-ubuntu-abstractions-updates.patch
  * debian/rules (this makes it the same as what was shipped in 10.04 LTS
    release):
    - don't ship aa-update-browser and its man page (requires
      0004-ubuntu-abstractions-updates.patch)
    - don't ship apparmor.d/local/ (requires 0003-local-includes.patch)
    - don't use dh_apparmor (not in Ubuntu 10.04 LTS)
    - don't ship chromium profile
  * remove debian/profiles/chromium-browser
  * remove debian/aa-update-browser*
  * debian/apparmor-profiles.postinst: revert to that in lucid release
    (requires dh_apparmor and 0002-add-chromium-browser.patch)
  * remove debian/apparmor-profiles.postrm: doesn't make sense without
    0002-add-chromium-browser.patch
  * debian/control:
    - revert Build-Depends on debhelper (>= 5)
    - revert Standards-Version to 3.8.4
    - revert Vcs-Bzr
    - use Conflicts/Replaces version that was in Ubuntu 10.04 LTS
  * debian/patches/0011-lucid-compat-dbus.patch: move /var/lib/dbus/machine-id
    back into dbus, since profiles on 10.04 LTS expect it there
  * debian/patches/0012-lucid-compat-kde.patch: add kde4-config to kde
    abstraction, since the firefox profile on Ubuntu 10.04 LTS expects it to
    be there

apparmor (2.5.1-0ubuntu0.10.10.2) maverick-proposed; urgency=low

  * New upstream release (LP: #660077)
    - The following patches were refreshed:
      + 0001-fix-release.patch
      + 0003-local-includes.patch
      + 0004-ubuntu-abstractions-updates.patch
      + 0008-lp648900.patch: renamed as 0005-lp648900.patch
    - The following patches were dropped (included upstream):
      + 0005-lp601583.patch
      + 0006-network-interface-enumeration.patch
      + 0007-gnome-updates.patch
  * debian/patches/0006-testsuite-fixes.patch: testsuite fixes from head
    of 2.5 branch. These are needed for QRT and SRU testing (LP: #652211)
  * debian/patches/0007-honor-cflags.patch: have the parser makefile honor
    CFLAGS environment variable. Brings back missing symbols for the retracer
  * debian/patches/0008-lp652674.patch: fix warnings for messages without
    denied or requested masks (LP: #652674)
  * debian/apparmor.init: fix path to aa-status (LP: #654841)
  * debian/apport/source_apparmor.py: apport hook should use
    root_command_hook() for running apparmor_status (LP: #655529)
  * debian/apport/source_apparmor.py: use ProcKernelCmdline and don't clobber
    cmdline details (LP: #657091)
  * debian/{rules,control}: move apache2 abstractions into the base package
    so we can put ...

Changed in apparmor (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
Maxime Chavagne (a-maxime) wrote :

I have the same bug from PDF document with HTTP links. I am running Ubuntu 11.10 oneiric and Firefox 13.0.
When i click on a link in a pdf document in evince i have the message :
"Impossible d'ouvrir le lien externe
L'exécution du processus fils « firefox » a échoué (Permission non accordée)"
and the link is not opened.

I have this line in /etc/apparmor.d/abstractions/ubuntu-browsers :
/usr/lib/firefox-*/firefox.sh PUx,

And it should be
/usr/lib/firefox/firefox.sh PUx,
or
/usr/lib/firefox*/firefox.sh PUx,

If i list /usr/lib I have :

# ls /usr/lib/ | grep firefox
firefox
firefox-3.6.10
firefox-addons

If I change the line in /etc/apparmor.d/abstractions/ubuntu-browsers and restart apparmor it works.

Maxime Chavagne (a-maxime) wrote :

Do I have to post a new bug or is it OK in here ?

Jamie Strandboge (jdstrand) wrote :

Maxime, you are almost certainly seeing bug #990931, which was fixed yesterday.

Maxime Chavagne (a-maxime) wrote :

That's right. Thanks a lot !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers