aa-notify difficult to use with gnome-shell

Bug #1681908 reported by Jamie Strandboge on 2017-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Medium
Jamie Strandboge

Bug Description

aa-notify currently calls notify-send with urgency of 'critical'. In gnome-shell critical urgency notifications result in a notification that must be explicitly clicked to dismiss (ie, they don't time out) and gnome-shell does not honor --expire-time with (at least) critical urgency. In other popular DEs critical urgency notifications time out. We should adjust the urgency to 'normal' to obtain intended behavior across DEs.

Changed in apparmor (Ubuntu):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.11.0-2ubuntu4

---------------
apparmor (2.11.0-2ubuntu4) zesty; urgency=medium

  * debian/patches/aa-notify-urgency-normal.patch: adjust the notify-send
    urgency to 'normal' to accommodate gnome-shell (LP: #1681908)

 -- Jamie Strandboge <email address hidden> Tue, 11 Apr 2017 18:34:18 +0000

Changed in apparmor (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers