Ship library in /lib, not /usr

Bug #1397960 reported by Martin Pitt on 2014-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apparmor (Debian)
Fix Released
Unknown
apparmor (Ubuntu)
High
Martin Pitt
Vivid
High
Martin Pitt

Bug Description

In bug 1396270 we enabled AppArmor support in systemd. However, that breaks on machines where /usr is on a separate partition, so we must move libapparmor1 from /usr to the root partition.

Martin Pitt (pitti) on 2014-12-01
Changed in apparmor (Ubuntu Vivid):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
milestone: none → ubuntu-14.12
tags: added: aa-systemd
Changed in apparmor (Debian):
status: Unknown → New
Martin Pitt (pitti) on 2014-12-01
Changed in apparmor (Ubuntu Vivid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.8.98-0ubuntu4

---------------
apparmor (2.8.98-0ubuntu4) vivid; urgency=medium

  * Ship libapparmor in /lib instead of /usr as we want to use it in systemd
    now. (LP: #1397960)
 -- Martin Pitt <email address hidden> Mon, 01 Dec 2014 15:37:32 +0100

Changed in apparmor (Ubuntu Vivid):
status: Fix Committed → Fix Released
Changed in apparmor (Debian):
status: New → Fix Committed
Changed in apparmor (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.