gnome-screensaver is running twice and prompts twice to unlock

Bug #1288241 reported by Jamie Strandboge on 2014-03-05
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
High
Jamie Strandboge

Bug Description

$ ps auxww|grep [g]nome-screensaver
jamie 3180 0.0 0.2 441840 23612 ? Sl Mar04 0:05 /usr/bin/gnome-screensaver --no-daemon
jamie 3944 0.0 0.2 437496 23280 ? Sl Mar04 0:00 /usr/bin/gnome-screensaver --no-daemon

The symptoms appear the same as bug #556255, but this is on Trusty. This has been happening off and on for a couple months.

Nothing in ~/.config/gnome-session/saved-session/, not listed in ~/.config/autostart, and nothing in ~/.config/upstart/. I do have this in /etc/xdg/autostart/:
-rw-r--r-- 1 root root 518 Feb 9 2013 gnome-screensaver.desktop
-rw-r--r-- 1 root root 466 Mar 30 2010 gnome-screensaver.desktop.dpkg-old

but as you can see, the timestamp on gnome-screensaver.desktop is quite old and this only started happening in the last couple of months. Perhaps this is related to the supposed upstart race in bug #1271591?

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-screensaver 3.6.1-0ubuntu9
ProcVersionSignature: Ubuntu 3.13.0-14.34-generic 3.13.5
Uname: Linux 3.13.0-14-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 5 06:59:16 2014
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GsettingsGnomeSession:
 org.gnome.desktop.session session-name 'gnome'
 org.gnome.desktop.session idle-delay uint32 600
InstallationDate: Installed on 2011-06-28 (980 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110425.2)
SourcePackage: gnome-screensaver
UpgradeStatus: Upgraded to trusty on 2013-11-04 (120 days ago)

Jamie Strandboge (jdstrand) wrote :
dino99 (9d9) wrote :

Cant confirm here on Trusty i386:

oem@dev32:~$ ps auxww|grep [g]nome-screensaver
oem 2103 0.0 0.3 178320 16180 ? Sl 07:20 0:06 /usr/bin/gnome-screensaver --no-daemon
oem@dev32:~$

but what is strange for that LTS release is : we are mixing 3.6, 3.8 and 3.10 gnome packages. That gnome-screensaver is a 3.6 one for example. Should be a good decision to only have 3.10 packages at least (or better, as 3.12 is very close now, and even better than 3.10).

Jamie Strandboge (jdstrand) wrote :

Note, this doesn't *always* happen, it only *sometimes* happens (but it does seem most of the time for me).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

Adding a lightdm task too. Perhaps it is actually something in the session. Please reassign as necessary.

dino99 (9d9) wrote :

Checked again, as im using lightdm by default (gdm also installed by gnome-shell)

oem@dev32:~$ ps auxww|grep [g]nome-screensaver
oem 2224 0.0 0.3 179692 14220 ? Sl 06:23 0:01 /usr/bin/gnome-screensaver --no-daemon
oem@dev32:~$

So it seems "always" clean on my system.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Sergei Solo (solomatkins) wrote :

This bug affects me too! (see more details https://bugs.launchpad.net/bugs/1295673)

And I think it associated with https://bugs.launchpad.net/ubuntu/+source/systemd-shim/+bug/1184262
Becouse:

When laptop suspending, before display turns off and laptop become fully suspended - I see Default Ubuntu lock screen and hear Ubuntu notice sound.

May be somewhere added second lock screen call. Becouse it seems like lock screen calls before suspend and after wake up...

Sergei Solo (solomatkins) wrote :

It seems that gnome-session reloading before suspend. Because when I click to Suspend - display blink with black screen ones and after, about 4-5 seconds I see ordinary desktop and folders.

Second lock screen process name (Gnome Lock screen) is "gnome-screensaver-dialog".

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in lightdm (Ubuntu):
importance: Undecided → High
Changed in gnome-screensaver (Ubuntu):
importance: Undecided → High
zwigno (zwigno) wrote :

This happens to me even without suspending.

Jamie Strandboge (jdstrand) wrote :

This happens to me with and without suspending.

tags: added: rls-t-incoming
Jamie Strandboge (jdstrand) wrote :

Looked at this slightly more and have more information:
$ ps auxww|grep [g]nome-screen
jamie 3033 0.0 0.2 511004 18932 ? Sl Mar24 0:10 /usr/bin/gnome-screensaver --no-daemon
jamie 3657 0.0 0.2 506844 16460 ? Sl Mar24 0:07 /usr/bin/gnome-screensaver --no-daemon

$ cat /proc/3033/environ | tr '\0' '\n'|grep UPSTART_SESSION
UPSTART_SESSION=unix:abstract=/com/ubuntu/upstart-session/1000/2579
$ cat /proc/3657/environ | tr '\0' '\n'|grep UPSTART_SESSION
UPSTART_SESSION=unix:abstract=/com/ubuntu/upstart-session/1000/2579

$ cat /proc/3033/environ | tr '\0' '\n'|grep DBUS_SESSION
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ZUvIbevG83,guid=269ab2f67b14acf19089d23953308de7
$ cat /proc/3657/environ | tr '\0' '\n'|grep DBUS_SESSION
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-y9007CBDK2,guid=4a97bdd2ecc021bd3585368753308de8

The two gnome-screensavers are using two different buses.

Jamie Strandboge (jdstrand) wrote :

Do other people experiencing this bug have /etc/X11/Xsession.d/90apparmor-notify installed?

Jamie Strandboge (jdstrand) wrote :

Actually, in my case it was apparmor-notify. It was starting via the old /etc/X11/Xsession.d mechanism which made it start on a different bus. Moving the autostart to /etc/xdg/autostart fixes this issue for me. Thanks to Sebastien and Marc for helping me diagnose this. Assigning to myself-- I'll fix it in the next apparmor upload. If people are still seeing this issue and they do not have apparmor-notify installed, please file a new bug.

no longer affects: lightdm (Ubuntu)
Changed in gnome-screensaver (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Jamie Strandboge (jdstrand)
affects: gnome-screensaver (Ubuntu) → apparmor (Ubuntu)
Changed in apparmor (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.8.95~2430-0ubuntu3

---------------
apparmor (2.8.95~2430-0ubuntu3) trusty; urgency=medium

  [ Jamie Strandboge ]
  * debian/lib/apparmor/functions: properly calculate number of profiles in
    /var/lib/apparmor/profiles (LP: #1295816)
  * autostart aa-notify via /etc/xdg/autostart instead of /etc/X11/Xsession.d
    (LP: #1288241)
    - remove debian/notify/90apparmor-notify
    - add debian/notify/apparmor-notify.desktop
    - debian/apparmor-notify.install: adjust for the above
    - add debian/apparmor-notify.maintscript to remove 90apparmor-notify
  * debian/notify/notify.conf: use_group should be set to "sudo" instead of
    "admin" (LP: #1009666)

  [ Tyler Hicks ]
  * debian/patches/initialize-mount-flags.patch: Initialize the variables
    containing mount rule flags to zero. Otherwise, the parser may set
    unexpected bits in the mount flags field for rules that do not specify
    mount flags. The uninitialized mount flag variables may have caused
    unexpected AppArmor denials during mount mediation. (LP: #1296459)
  * debian/patches/fix-typo-in-dbus_write.patch: Fix a bug in the
    apparmor/aa.py module that caused the utilities in the apparmor-utils
    package to write out network rules instead of dbus rules
  * debian/patches/limited-mount-rule-support.patch: Fix a bug in the
    apparmor/aa.py module that caused the utilities in the apparmor-utils
    package to traceback when encountering a mount rule (LP: #1294825)
  * debian/patches/bare-capability-rule-support.patch: Fix a bug in the
    apparmor/aa.py module that caused the utilities in the apparmor-utils
    package to traceback when encountering a bare capability rule
    (LP: #1294819)
  * debian/patches/check-config-for-sysctl.patch,
    debian/patches/increase-swap-size.patch: Fix bugs in the regression test
    suite that caused errors when running on ppc64el
  * debian/patches/test-v6-policy.patch,
    debian/patches/test-mount-mediation.patch: Improve the regression tests
    by increasing the mount rule test coverage
 -- Tyler Hicks <email address hidden> Thu, 27 Mar 2014 14:12:29 -0500

Changed in apparmor (Ubuntu):
status: Fix Committed → Fix Released
Andreas (anbog) wrote :

I'm affected by this bug with apparmor at version: 2.8.95~2430-0ubuntu3.
I don't have apparmor-notify installed.

I also get it without suspending, but it seems to be more likely to happen if the computer has been on the lockscreen for a while.

Jamie Strandboge (jdstrand) wrote :

Andreas, yours is a different issue. Please file a new bug.

Sergei Solo (solomatkins) wrote :

I install all updates available on April 10, bug still exist. I captured video that showing what is going on, you can look:
http://www.youtube.com/watch?v=ZOO-gAbAox4

Only on 36 second it become suspended (suspending took 27 seconds).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers