please have apparmor-notify Recommends libnotify-bin instead of Depends

Bug #1061879 reported by Jamie Strandboge on 2012-10-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apparmor (Ubuntu)
Medium
Jamie Strandboge
Precise
Medium
Steve Beattie
Quantal
Medium
Steve Beattie
Raring
Medium
Jamie Strandboge

Bug Description

aa-notify works just fine without libnotify-bin in server environments. Eg, I remove libnotify-bin and libnotify4 (using --force-depends) on a precise system and then do:

$ sudo tcpdump -i eth0 -n -s 0 -w /foo
tcpdump: /foo: Permission denied
$ sudo aa-notify -s 1 -v
Profile: /usr/sbin/tcpdump
Operation: mknod
Name: /foo
Denied: c
Logfile: /var/log/kern.log

AppArmor denial: 1 (since Wed Oct 3 15:45:04 2012)
For more information, please see: https://wiki.ubuntu.com/DebuggingApparmor

Changed in apparmor (Ubuntu):
assignee: nobody → Steve Beattie (sbeattie)
importance: Undecided → Medium
status: New → Triaged
Changed in apparmor (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.8.0-0ubuntu5

---------------
apparmor (2.8.0-0ubuntu5) quantal; urgency=low

  [ Micah Gersten ]
  * Allow /etc/vdpau_wrapper.cfg r and /var/lib/xine/gxine.desktop r
    in the multimedia browser abstraction (LP: #1057642)
    - update profiles/apparmor.d/abstractions/ubuntu-browsers.d/multimedia

  [ Steve Beattie ]
  * debian/control: make libnotify-bin a Recommends rather than a
    Depends for use in server environments (LP: #1061879)
  * debian/patches/0020-coredump_tests.patch: fix coredump regression
    tests (LP: #1050430)
  * debian/patches/0021-webapps_abstraction.patch: add a few items
    triggered by using and installing webapps in firefox (LP: #1056418)
  * debian/patches/0022-aa-decode-stdin.patch: fix aa-decode to process
    stdin correctly and decode encoded profiles names
 -- Steve Beattie <email address hidden> Tue, 09 Oct 2012 12:44:56 -0700

Changed in apparmor (Ubuntu Quantal):
status: Triaged → Fix Released
Steve Beattie (sbeattie) wrote :

I'm reopening this after discussing it with Daviey;. he felt the dependency on libnotify-bin should be a Suggests: and that for desktop environments we assume that libnotify-bin will already be installed.

Poking at the rdepends for libnotify-bin, it's already a dependency of ubuntu-desktop, ubuntu-gnome-desktop, xubuntu-desktop, ubuntustudio-desktop, and mythtv-frontend. It seems kubuntu-desktop is the only location where this assumption might be a problem, but I don't know for sure whether libnotify works in that desktop environment anyway.

Changed in apparmor (Ubuntu Quantal):
status: Fix Released → Confirmed
Steve Beattie (sbeattie) wrote :

To followup, the reason to make it a suggests would be so that the apparmor-notify could be installed on servers without pulling in a bunch of X libraries, even if recommends is enabled (which it is by default even on ubuntu-server).

Marc Deslauriers (mdeslaur) wrote :

Too late for Quantal, let's do this in R.

Changed in apparmor (Ubuntu Quantal):
milestone: ubuntu-12.10 → none
Jamie Strandboge (jdstrand) wrote :

So, the hard dependency is fixed for 12.10 so I am going to mark it as 'Fix Released'. I am going to open a raring and precise task with the understanding that we should use 'Suggests' instead.

Changed in apparmor (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in apparmor (Ubuntu Raring):
assignee: Steve Beattie (sbeattie) → Jamie Strandboge (jdstrand)
status: Confirmed → In Progress
Changed in apparmor (Ubuntu Precise):
status: New → Triaged
assignee: nobody → Steve Beattie (sbeattie)
milestone: none → precise-updates
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.8.0-0ubuntu9

---------------
apparmor (2.8.0-0ubuntu9) raring; urgency=low

  * debian/control: make libnotify-bin a Suggests rather than a Recommends
    since it is assumed to already be installed on the desktop and so server
    environments don't have to pull in a lot of X dependencies (LP: #1061879)

apparmor (2.8.0-0ubuntu8) raring; urgency=low

  [ Steve Beattie ]
  * 0024-lp1091642-parser-reset_matchflags.patch: prevent reuse of
    matchflags in parser dfa backend and add testcase demonstrating the
    problem (LP: #1091642)

  [ Jamie Strandboge ]
  * debian/debhelper/postinst-apparmor: quote all occurences of #PROFILE#.
 -- Jamie Strandboge <email address hidden> Tue, 18 Dec 2012 10:47:50 -0600

Changed in apparmor (Ubuntu Raring):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers