calendar app does not start

Bug #1548888 reported by Renato Araujo Oliveira Filho on 2016-02-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apparmor-easyprof-ubuntu (Ubuntu)
Undecided
Jamie Strandboge
ubuntu-calendar-app (Ubuntu)
Undecided
Renato Araujo Oliveira Filho

Bug Description

Calendar app does not start with the latest image, due a apparmor policy:

Image: Ubuntu 16.04(r467)

Syslog:

Feb 23 14:47:27 ubuntu-phablet dbus[1823]: apparmor="DENIED" operation="dbus_method_call" bus="session" path="/org/gnome/evolution/dataserver/Subprocess/2680/2" interface="org.gnome.evolution.dataserver.Calendar" member="Close" mask="send" name=":1.87" pid=3862 label="com.ubuntu.calendar_calendar_0.4.latest" peer_pid=2680 peer_label="unconfined"

As workaround to get the app working you can manually edit '/var/lib/apparmor/profiles/click_com.ubuntu.calendar_calendar_0.4.latest'

Adding:

dbus (receive, send)
       bus=session
       interface=org.gnome.evolution.dataserver.Calendar
       peer=(label=unconfined),

After save it run:
    sudo apparmor_parser -r /var/lib/apparmor/profiles/click_com.ubuntu.calendar_calendar_0.4.latest

Changed in ubuntu-calendar-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Jamie Strandboge (jdstrand) wrote :

Is this needed for just xenial or for OTA? If for OTA, which?

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-calendar-app (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

I see Ubuntu 16.04(r467) in the bug description now. I'll fix it there-- if it needs to be fixed in the overlay ppa, add a task for it.

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Incomplete → In Progress
Jamie Strandboge (jdstrand) wrote :

Note, this is the rule I am using instead of the workaround rule:
dbus (receive, send)
     bus=session
     path=/org/gnome/evolution/dataserver/Subprocess{,/**}
     interface=org.gnome.evolution.dataserver.Calendar
     peer=(label=unconfined),

Please report back if this isn't enough.

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Jamie Strandboge (jdstrand)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 16.04.4

---------------
apparmor-easyprof-ubuntu (16.04.4) xenial; urgency=medium

  [ Jamie Strandboge ]
  * adjust cpuinfo_max_freq access for newer kernels
  * ubuntu/calendar: update policy to account for newer EDS Subprocess path
    on the org.gnome.evolution.dataserver.Calendar interface (LP: #1548888)

 -- Jamie Strandboge <email address hidden> Tue, 23 Feb 2016 16:50:56 -0600

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers