dekko cant display content anymore (with apparmor denials for /run/shm/WK2SharedMemory.*)

Bug #1377648 reported by Oliver Grawert on 2014-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apparmor-easyprof-ubuntu (Ubuntu)
Critical
Jamie Strandboge
apparmor-easyprof-ubuntu (Ubuntu RTM)
Critical
Jamie Strandboge

Bug Description

since a while dekko does not display any mail content for me anymore ... checking syslog i see a lot of:

Oct 5 16:41:33 ubuntu-phablet kernel: [ 6327.720986] (0)[16417:dekko]type=1400 audit(1412520093.649:761): apparmor="DENIED" operation="mknod" profile="com.ubuntu.developer.dpniel.dekko_dekko_0.2.9" name="/run/shm/WK2SharedMemory.3491348362" pid=16417 comm="dekko" requested_mask="c" denied_mask="c" fsuid=32011 ouid=32011

Dan Chapman  (dpniel) wrote :

It looks like this bug was introduced in apparmor-easyprof-ubuntu version 1.2.28 with this change

 * ubuntu/1.[12]/ubuntu-{sdk,webapp}: remove no longer needed rule for
    /{,run/}shm/shm/WK2SharedMemory.[0-9]* (LP: #1197060)

see https://bugs.launchpad.net/ubuntu/+source/apparmor-easyprof-ubuntu/+bug/1197060/comments/7

Changed in dekko:
status: New → Confirmed
importance: Undecided → Critical
Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Jamie Strandboge (jdstrand)
Changed in dekko:
status: Confirmed → Invalid
Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → Critical
status: New → In Progress
tags: added: rtm14 touch-2014-10-09
Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.2.34

---------------
apparmor-easyprof-ubuntu (1.2.34) utopic; urgency=medium

  * ubuntu/1.[12]/ubuntu-{sdk,webapp}: re-add still needed rule for
    /{,run/}shm/shm/WK2SharedMemory.[0-9]*. This needs to stay until qtwebkit
    is removed from the image (LP: #1377648)
 -- Jamie Strandboge <email address hidden> Mon, 06 Oct 2014 07:10:09 -0500

Changed in apparmor-easyprof-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
Changed in apparmor-easyprof-ubuntu (Ubuntu RTM):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers