click apps need read access to /custom/usr/share/themes

Bug #1229471 reported by Chris Wayne on 2013-09-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Sevilerow project
Undecided
Unassigned
apparmor-easyprof-ubuntu (Ubuntu)
High
Jamie Strandboge
Saucy
High
Jamie Strandboge

Bug Description

Click apps need to get access to /custom/usr/share/themes in order to use the customized themes in the devel-customized image.

The denial looks like this currently:
kern.log:Sep 23 22:11:33 ubuntu-phablet kernel: [ 1904.165328] type=1400 audit(1379974293.057:158): apparmor="DENIED" operation="open" parent=869 profile="com.ubuntu.developer.cwayne18.uwoot_uwoot_0.2" name="/custom/usr/share/themes/UbuntuCustom/Themes/Custom/MainViewStyle.qml" pid=5946 comm="QThread" requested_mask="r" denied_mask="r" fsuid=32011 ouid=1000

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: apparmor-easyprof-ubuntu 1.0.31
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu4
Architecture: amd64
Date: Mon Sep 23 19:39:30 2013
InstallationDate: Installed on 2013-07-26 (59 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: apparmor-easyprof-ubuntu
UpgradeStatus: Upgraded to saucy on 2013-08-15 (39 days ago)

Chris Wayne (cwayne18) wrote :
Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
assignee: nobody → Jamie Strandboge (jdstrand)
importance: Undecided → High
status: New → Triaged
Matt Fischer (mfisch) wrote :

We need more than just the folder mentioned. I'm seeing errors trying to access the dconf profile which lives in /etc/dconf_profile

Jamie Strandboge (jdstrand) wrote :

Regarding the dconf error-- confined apps should not be using gsettings because there is no mediation for it yet. There is a blueprint for it, but it has been postponed for 13.10 and it is far too late to implement it. What requires using gsettings? What are the steps to reproduce this so I can see all that apparmor errors?

Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: Triaged → Incomplete
Chris Wayne (cwayne18) wrote :

THe dconf error has nothing to do with the click apps, so isn't really relevant for this particular bug. The error is here:

Sep 23 22:12:40 ubuntu-phablet kernel: [ 23.656432] type=1400 audit(1379974360.767:48): apparmor="DENIED" operation="open" parent=1954 profile="/usr/lib/telepathy/mission-control-5" name="/custom/etc/dconf_profile" pid=1955 comm="mission-control" requested_mask="r" denied_mask="r" fsuid=32011 ouid=1000

Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: Incomplete → Triaged
Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor-easyprof-ubuntu - 1.0.34

---------------
apparmor-easyprof-ubuntu (1.0.34) saucy; urgency=low

  * ubuntu-* templates: allow read access to themes in /custom (LP: #1229471)
 -- Jamie Strandboge <email address hidden> Tue, 24 Sep 2013 10:27:02 -0500

Changed in apparmor-easyprof-ubuntu (Ubuntu Saucy):
status: In Progress → Fix Released
Matt Fischer (mfisch) on 2013-09-25
Changed in sevilerow:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers