Use PNG or SVG instead of GIF

Bug #889889 reported by Fred on 2011-11-13
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Adium Theme Ubuntu
Undecided
Unassigned
OpenSSL
New
Undecided
Unassigned
ace (Ubuntu)
Undecided
Unassigned
app-install-data-ubuntu (Ubuntu)
Undecided
Unassigned
blender (Ubuntu)
Undecided
Unassigned
chardet (Ubuntu)
Undecided
Unassigned
cups (Ubuntu)
Undecided
Unassigned
dvd+rw-tools (Ubuntu)
Undecided
Unassigned
foo2zjs (Ubuntu)
Undecided
Unassigned
libcgi-pm-perl (Ubuntu)
Undecided
Unassigned
openssl (Ubuntu)
Undecided
Unassigned
python3.4 (Ubuntu)
Undecided
Unassigned
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Use modern file formats such as PNG or SVG instead of the legacy GIF file formats.

$ find /usr -name "*.gif"

Related branches

tags: added: gif png svg
description: updated
tags: added: bitesize
removed: gif png svg
Changed in libreoffice (Ubuntu):
status: New → Invalid
Fred (eldmannen+launchpad) wrote :
Download full text (17.5 KiB)

OpenOffice.org is guilty!
$ find /usr -name "*.gif" | grep libreoffice

/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/tutorial_background.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/spain.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/taiwan.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/finland.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/brasil.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/netherlands.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/italia.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/polska.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/denmark.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/greece.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/sweden.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/usa.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/ftpunknown.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/ftperror.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/ftpconnecting.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/france.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/ftpconnected.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/russia.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/turkey.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/china.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/japan.gif
/usr/lib/libreoffice/basis3.4/share/template/wizard/bitmap/portugal.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/html.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/writer.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/media.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/impress.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/pdf.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/fls.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/graphics.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/calc.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/other.gif
/usr/lib/libreoffice/basis3.4/share/config/wizard/web/images/draw.gif
/usr/lib/libreoffice/basis3.4/share/gallery/flowers.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/gryrulr1.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blurulr4.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/redrulr1.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blurulr3.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/grnrulr4.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blurulr2.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/redrulr5.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blurulr6.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blkballs.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/redrulr4.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/gryrulr3.gif
/usr/lib/libreoffice/basis3.4/share/gallery/rulers/blurulr5.gif
/usr/lib/libreoffice...

Changed in libreoffice (Ubuntu):
status: Invalid → Confirmed

Fred, thank you for reporting this and helping make Ubuntu better. Please do not mark bugs you reported as confirmed. For more on bug status please see: https://wiki.ubuntu.com/Bugs/Status

Regarding your suggestion to replace GIF with PNG or SVG, could you please describe how this change would benefit LibreOffice specifically?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete

Christopher:
SVG is scalable, so it is something way different than the other two formats - and perhaps a solution to problems with pixelated icons as can be commonly seen when icon of proper size is missing (and smaller is inputed instead).
PNG has better compresion than GIF.

On most images, except for some cases of small images, GIF will be bigger than indexed PNG.
PNG has much more transparency options (alpha channel included).
GIF is limited to 8-bit indexed color, while PNG gives a much wider range of color depths, including 24-bit (8 bits per channel) and 48-bit (16 bits per channel) truecolor. Add alpha channel to this and you have up to 64 bits per pixel (before compression).
GIF supports animated images, but I can hardly imagine where in system could we find a need for animated GIFs.

And as an interesting fact (not really an argument, since it concerns the Web) GIF images render slower than PNG images do, as was stated by W3C.

I am sorry for the double post, hoped for the possibility of later edit.

The GIFs which were listed by Fred come mainly from the art gallery and some of them look not only bad, but also... old. Some bullets are nontransparent, while pictures in the gallery folder suffer from low colour depth.
Perhaps they weren't changed over the course of years as this is not exactly the most important thing to change, but this bug could be fair enough changed into a wishlist entry for a new set of images (LibreOffice Impress being the most beneficial).

Fred, , this is:
- a clearcut upstream issue. Your welcome to send this to the developers of the software by following the instructions at http://wiki.documentfoundation.org/BugReport
- won't be fixed in LibreOffice Packaging
Resolving as Won't Fix in LibreOffice Packaging. This does not mean the issue will not be cared about, but if it is cared about (even by Ubuntu/Canonical contributors), it is done upstream at LibreOffice.

libreoffice (Ubuntu) => Won't Fix

Changed in libreoffice (Ubuntu):
status: Incomplete → Won't Fix
Charles Plessy (plessy) wrote :

Please remove njplot from the list of the packages affected by LP#889889.

Changed in njplot (Ubuntu):
status: New → Invalid
Fred (eldmannen+launchpad) wrote :

But njplot is affected.
/usr/share/app-install/icons/njplot.gif

Charles Plessy (plessy) wrote :

> But njplot is affected.
> /usr/share/app-install/icons/njplot.gif

This file belongs to the app-install-data package: http://packages.ubuntu.com/precise/all/app-install-data/filelist

And yes, I agree that a screenshot does not make a nice icon :)

Matthias Klose (doko) on 2012-01-05
Changed in python3.2 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Jamie Strandboge (jdstrand) wrote :

In openssl the only gif is their logo in their documentation which is not displayed anywhere prominently in Ubuntu. We are not going to diverge from upstream on this.

Changed in openssl (Ubuntu):
status: New → Won't Fix
Fred (eldmannen+launchpad) wrote :

Jamie Strandboge (jdstrand),
I do not suggest we diverge from upstream.
It should be fixed upstreams.

The GIF images coming with the CUPS package are only part of the documentation. They are not displayed during normal use of CUPS. Therefore we will not diverge from upstream to replace the GIF images by another format. Please report the suggestion to replace the GIF images by a more modern format to the upstream bug tracker:

http://www.cups.org/str.php

Closing task for the Ubuntu package of CUPS ...

Changed in cups (Ubuntu):
status: New → Won't Fix

foo2zjs only contains one GIF image which is used for a little GUI tool to reset a paper-out status of certain printer models (only HP LaserJet 1018/1020/P10xx). This tool is written in the rather unusal TCL/TK/Tix language and requires the deprecated usblp kernel module. Therefore it does not work on standard Ubuntu installations and so the GIF image does not get used. Therefore I am closing the Ubuntu package task for foo2zjs. Feel free to report your suggestion upstream on http://foo2zjs.rkkda.com/forum/.

Changed in foo2zjs (Ubuntu):
status: New → Won't Fix
Changed in adium-theme-ubuntu (Ubuntu):
status: New → Confirmed
affects: adium-theme-ubuntu (Ubuntu) → adium-theme-ubuntu
Changed in adium-theme-ubuntu:
assignee: nobody → Daniel Polehn (dpolehn-gmail)
Changed in adium-theme-ubuntu:
status: Confirmed → In Progress
affects: app-install-data-ubuntu (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → app-install-data-ubuntu
Changed in adium-theme-ubuntu:
status: In Progress → Fix Committed
Changed in adium-theme-ubuntu:
assignee: Daniel Polehn (dpolehn-gmail) → nobody
status: Fix Committed → Fix Released
tags: removed: bitesize
Fred (eldmannen+launchpad) wrote :

Isn't this bitesize?

Isn't it just run "convert file.gif file.png" and its done?

Micah Gersten (micahg) wrote :

No, we don't want a diff for this in Ubuntu. This issue needs to be dealt with upstream.

Fred (eldmannen+launchpad) wrote :

Yes, this needs to be dealt with upstreams.
Doesn't upstreams use Launchpad?
Can upstreams be notified?

Adolfo Jayme (fitojb) on 2015-02-16
no longer affects: openssl (Ubuntu)
no longer affects: cups (Ubuntu)
no longer affects: libreoffice (Ubuntu)
no longer affects: foo2zjs (Ubuntu)
no longer affects: python3.2 (Ubuntu)
no longer affects: njplot (Ubuntu)
affects: app-install-data-ubuntu → app-install-data-ubuntu (Ubuntu)
Fred (eldmannen+launchpad) wrote :

/usr/share/foo2zjs/hplj1020_icon.gif
/usr/share/ipython/notebook/static/components/jquery-ui/themes/smoothness/images/animated-overlay.gif
/usr/share/javascript/jquery-ui/css/smoothness/images/animated-overlay.gif
/usr/share/javascript/jquery-ui/themes/smoothness/images/animated-overlay.gif
/usr/share/javascript/jquery-ui/themes/base/images/animated-overlay.gif
/usr/share/javascript/mathjax/unpacked/jax/output/HTML-CSS/blank.gif
/usr/share/cups/doc-root/images/*.gif
/usr/share/software-center/images/spinner.gif
/usr/share/atom/resources/app/static/images/transparent-background.gif
/usr/share/atom/resources/app/static/images/octocat-spinner-128.gif
/usr/share/atom/resources/app/apm/node_modules/npm/node_modules/retry/equation.gif
/usr/share/doc/libcgi-pm-perl/examples/dna.small.gif
/usr/share/doc/libcgi-pm-perl/examples/wilogo.gif
/usr/share/doc/dvd+rw-tools/isofs4gb.gif
/usr/share/doc/openssl/openssl_button.gif
/usr/share/app-install/icons/njplot.gif
/usr/share/tcltk/tk8.6/images/*.gif
/usr/share/blender/scripts/addons/netrender/css/images/themes.gif
/usr/share/blender/scripts/addons/netrender/css/images/themes-preview.gif
/usr/lib/thunderbird/Throbber-small.gif
/usr/lib/firefox/Throbber-small.gif
/usr/lib/libreoffice/share/gallery/www-graf/*.gif
/usr/lib/libreoffice/share/gallery/bullets/*.gif
/usr/lib/libreoffice/share/gallery/htmlexpo/*.gif
/usr/lib/libreoffice/share/gallery/*.gif
/usr/lib/libreoffice/share/gallery/www-back/*.gif
/usr/lib/libreoffice/share/config/wizard/web/images/*.gif
/usr/lib/libreoffice/share/template/wizard/bitmap/*.gif
/usr/lib/python3.4/idlelib/Icons/*.gif

Adolfo Jayme (fitojb) on 2015-02-28
no longer affects: libreoffice (Ubuntu)
no longer affects: firefox (Ubuntu)
no longer affects: thunderbird (Ubuntu)
Matthew Paul Thomas (mpt) wrote :

> /usr/share/software-center/images/spinner.gif

Obviously, this is for an animation, which PNG and SVG alone cannot provide. (If an animation happens to have rotational symmetry, you can use CSS+JavaScript to rotate it, but that's needlessly complicated.) The same is probably true for all the other filenames in the list that contain "animated", "spinner", or "throbber". Unfortunately, GDK does not have any animated bitmap format built-in, and it depends on libpng which doesn't either. <https://bugzilla.gnome.org/show_bug.cgi?id=151281>

Changed in software-center (Ubuntu):
status: New → Invalid
Fred (eldmannen+launchpad) wrote :

I believe CSS can do animations without JavaScript.

Marc Deslauriers (mdeslaur) wrote :

I'm not fixing this in the Ubuntu openssl package, go bug upstream if you want them to change their image format.

Changed in openssl (Ubuntu):
status: New → Won't Fix
Matthias Klose (doko) wrote :

won't fix in the python3.4 package. please file a bug upstream

Changed in python3.4 (Ubuntu):
status: New → Won't Fix
Nazo (lovesyao) wrote :

$ dpkg -L blender | grep \\.gif
$ dpkg -L blender-data | grep \\.gif

no more gifs in blender

Changed in blender (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.