"Search applications" returns non existent applications - app-install-data is not up to date

Bug #800613 reported by Jean-Baptiste Lallement on 2011-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
app-install-data-ubuntu (Ubuntu)
Low
Unassigned

Bug Description

TEST CASE:
1. Click on 'Applications' launcher
2. On the search entry, select 'All applications'
3. Enter one of the following string "Device Manager", "Default Printer", "Album Shaper", "Alsa Mixer" and probably many others, and it may vary depending on your system.
4. Click on the application found.

Result:
Software-Center is launched and displays a "Not found' message.

This might be related to bug 799713

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 3.8.16-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,imgpng,regex,resize,mousepoll,vpswitch,grid,move,resizeinfo,place,snap,animation,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Wed Jun 22 12:33:42 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-05-16 (36 days ago)

Jean-Baptiste Lallement (jibel) wrote :

I don't think this can be defined as just a Unity problem, as doing the same search in software center itself also turns up these applications. But I can confirm this is what happens.

affects: unity (Ubuntu) → software-center (Ubuntu)
Changed in software-center (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Thanks, but I talked about s-c just as the result not the cause of the defect. The problem is the search returning non existent applications not the "not found" message in software-center. That's probably apt-xapian-index which indexes old stuff or doesn't clear old records.

Reassigning to Unity since that's where the bug occurs until further investigation but this report and bug 799713 are very likely duplicates.

affects: software-center (Ubuntu) → unity (Ubuntu)
affects: unity (Ubuntu) → app-install-data-ubuntu (Ubuntu)
Changed in app-install-data-ubuntu (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
summary: - "Search applications" returns non existent applications
+ "Search applications" returns non existent applications - app-install-
+ data is not up to date
Jean-Baptiste Lallement (jibel) wrote :

Fixed with
app-install-data-ubuntu (0.11.10.1) oneiric; urgency=low

  * updated for alpha2

 -- Michael Vogt <email address hidden> Mon, 04 Jul 2011 08:30:41 +0200

Changed in app-install-data-ubuntu (Ubuntu):
status: Triaged → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers