Amarok appears twice in Software center

Bug #782684 reported by DarkRedman on 2011-05-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
app-install-data-ubuntu (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

Hi everyone, I use Ubuntu 11.04 (fresh install) and software-center 4.0.1

I cliked on the blue link "Recommendentions" and in the list I saw "Amarok" package which appeared twice, I check differences, no differences neither the version package.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 4.0.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat May 14 17:16:40 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Robert Roth (evfool) wrote :

Amarok also appears twice in search results for Amarok, and also in the Sound and Video category, so the problem is not related to the recommandations, but to the fact that there are two amarok desktop files in the app-install-data package (http://bazaar.launchpad.net/~ubuntu-core-dev/app-install-data-ubuntu/ubuntu/view/head:/menu-data/kde4___amarok.desktop and http://bazaar.launchpad.net/~ubuntu-core-dev/app-install-data-ubuntu/ubuntu/view/head:/menu-data/kde4___amarok_containers.desktop), and software-center shows the apps based on this data. One of these desktop files should be removed from the app-install-data package to avoid having two amarok applications with exactly the same data (review, rating, description, etc) in Software-center. Reassigning this to the app-install-data package accordingly.

affects: software-center (Ubuntu) → app-install-data-ubuntu (Ubuntu)
Changed in app-install-data-ubuntu (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Robert Roth (evfool) on 2011-05-27
summary: - Amarok appears twice in recommendations
+ Amarok appears twice in Software center
Jjed (jjed) wrote :

Fixed in app-install-data-ubuntu 0.11.10.2. There was a flaw in our crawler blacklist that is now fixed.

Changed in app-install-data-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers