Wrong Firefox package is displayed by default in SC

Bug #602820 reported by Andrea Amoroso on 2010-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Michael Vogt
app-install-data-ubuntu (Ubuntu)
Low
Michael Vogt
firefox (Ubuntu)
Low
Unassigned

Bug Description

Software center in maverick , hides "technical items" by default.
And they are pretty well hidden![didnt notice the feature the first time i opened SC]

This hide is part of the cause of the problem here and the real problem is:
- The wrong package is being hidden by default. The package that is being displayed is the branding package and hence the "geeky" description
- May also be due to the actual firefox package having the description and title switched in list-view[also a problem in Lucid] + not having an Icon.

------
[Original Description]
The description of firefox in Software Center is geek, incomplete and doesn't spend words about the browser..
I really think it should be changed.. :)

Vikram Dhillon (dhillon-v10) wrote :

Andrea: Can you give an example of something you think that might be more appropiate, we can use that and merge it in with what we currently have.

Changed in hundredpapercuts:
importance: Undecided → Wishlist
status: New → Opinion
Andrea Amoroso (heiko81) wrote :

The actual description says:
"This package ships the Firefox branding bits. If you remove this package your user experience will become that of the abrowser."

I think that it should be modified like this:
"Firefox is one of the most popular web browser thanks to its security, stability, speed and much more. It is free and easy to use. It is also highly customizable to almost every desire. This package ships the Firefox branding bits. If you remove this package your user experience will become that of the abrowser."

Vish (vish) wrote :

Software center in maverick , hides "technical items" by default.
And they are pretty well hidden![didnt notice the feature the first time i opened SC]

This hide is part of the cause of the problem here and the real problem is:
- The wrong package is being hidden by default. The package that is being displayed is the branding package and hence the "geeky" description
- May also be due to the actual firefox package having the description and title switched in list-view[also a problem in Lucid] + not having an Icon.

Updating description and title

Vish (vish) wrote :
description: updated
Changed in hundredpapercuts:
importance: Wishlist → Low
status: Opinion → Triaged
Changed in firefox (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
summary: - firefox description in software center is geek and not at all complete
+ Wrong Firefox package being displayed by default in SC
summary: - Wrong Firefox package being displayed by default in SC
+ Wrong Firefox package is displayed by default in SC
Bilal Akhtar (bilalakhtar) wrote :

Does this bug affect Firefox? or Software center?

Changed in hundredpapercuts:
milestone: none → maverick-round-9-sc-metadata
Chris Coulson (chrisccoulson) wrote :

I'm not sure this is anything to do with firefox. Firefox has an appropriate description for each of it's binary packages (the description shown in software-center for firefox-gnome-support is an appropriate description for that package)

TBH, i'm not sure what I can do in the firefox packaging for this, it sounds more like a software-center issue

Vish (vish) wrote :

Opening SC task as per comment #6 .

Changed in software-center (Ubuntu):
importance: Undecided → Low
Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
Michael Vogt (mvo) on 2010-07-27
Changed in software-center (Ubuntu):
status: New → In Progress
affects: software-center (Ubuntu) → app-install-data-ubuntu (Ubuntu)
Andrew (and471) wrote :

With latest SC, I don't even get that 1st firefox item showing up. I shall have a look at this.

Andrew (and471) wrote :

Hmm, looking in Maverick on a daily ISO, this seems to be fixed, it points to the correct package and everything is as it should be.

Closing as it seems to be fixed, if anyone feels as tho it hasn't, please reopen

Changed in hundredpapercuts:
status: Triaged → Opinion
status: Opinion → Invalid
Changed in app-install-data-ubuntu (Ubuntu):
status: In Progress → Invalid
Vish (vish) wrote :

Andrew, the earlier screenshot was from Maverick. [note the 'hide' is a maverick feature]

Once Chris mentioned it wasnt a Firefox bug, Michael Vogt found the problem in app-install-data-ubuntu and hence the bug was set as 'in-progress' but he seems to have not mentioned this bug # while releasing app-install-data-ubuntu 0.10.10.3

Change was done in <http://bazaar.launchpad.net/%7Eubuntu-core-dev/app-install-data-ubuntu/ubuntu/revision/636/menu-data/firefox.desktop>

This was an app-install-data-ubuntu bug and not a firefox bug.

Changed in hundredpapercuts:
status: Invalid → Fix Released
assignee: nobody → Michael Vogt (mvo)
Changed in app-install-data-ubuntu (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: Invalid → Fix Released
Changed in firefox (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers