In search for "firefox", Firefox is result #9

Bug #231021 reported by Matthew Paul Thomas on 2008-05-16
10
Affects Status Importance Assigned to Milestone
app-install-data-ubuntu (Ubuntu)
Medium
Michael Vogt
Hardy
Medium
Michael Vogt

Bug Description

Binary package hint: gnome-app-install

Ubuntu 8.04, all updates installed

1. In the "All" category, with "All available applications" selected, search for "firefox" (without quotes).

What happens: The results begin with (1) Greasemonkey, (2) Sage, (3) the Web Developer toolbar, (4) the Firefox Launchpad plugin, (5) Ubuntu themes for Firefox, (6) the Ubuntu-it menu extension for Firefox, (7) Firefox Showcase, (8) the Macromedia, and then (9) Firefox itself.
What should happen: Firefox should be the first result.

TEST CASE:
1. install hardy
2. open gnome-app-install
3. search for firefox
4. verify that it is not on top

5. install app-install-data from hardy-proposed
6. open gnome-app-install
7. search for firefox
8. verify that its on top now

Confirmed on Kubuntu 8.04.

Changed in gnome-app-install:
status: New → Confirmed
Michael Vogt (mvo) wrote :

I analyzed the problem and it turns out that popularity data is screwed because of the switch from firefox-2 to firefox-3. A simple update of the popularity data from today gives the expected result (firefox on top). I prepare a SRU for this.

Cheers,
 Michael

Michael Vogt (mvo) on 2008-06-10
description: updated
Changed in gnome-app-install:
assignee: nobody → mvo
importance: Undecided → Medium
status: New → Fix Committed
Michael Vogt (mvo) on 2008-06-10
Changed in gnome-app-install:
assignee: nobody → mvo
importance: Undecided → Medium
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Uphaar Agrawalla (uphaar) wrote :

Tested, Firefox appears on top now.

Martin Pitt (pitti) wrote :

Copied to hardy-updates and intrepid.

Changed in app-install-data-ubuntu:
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers