SRU for zdesktop package

Bug #255666 reported by Michael Vogt on 2008-08-07
8
Affects Status Importance Assigned to Milestone
app-install-data-commercial (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: app-install-data-commercial

We we zdesktop now in the partner repository and in order to add it, we need to upload the attached diff.

TEST CASE:
1. use hardy
2. start gnome-app-install and switch to "Third party applications"
3. verfiy that it is not there and close gnome-app-install

4. install app-install-data-commercial from hardy-proposed
5. repeat 2
6. verfiy that it is now there
7. install it and see if it works

Michael Vogt (mvo) wrote :
Changed in app-install-data-commercial:
assignee: nobody → mvo
importance: Undecided → Medium
status: New → In Progress
Michael Vogt (mvo) on 2008-08-07
description: updated
Michael Vogt (mvo) on 2008-08-07
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in app-install-data-commercial:
status: In Progress → Fix Committed
Vadim Peretokin (vperetokin) wrote :

I enabled -proposed, switch to Main Server, but I don't see an upgrade available for gnome-app-install

Michael Vogt (mvo) wrote :

@Vadmin: Thanks for checking that out. The update should be for "app-install-data-commercial". Do you see that?

Vadim Peretokin (vperetokin) wrote :

Ah, yes I saw that.

I can confirm that it works, but only partially - the application is missing a description and everything: http://img145.imageshack.us/img145/8712/screenshot2kj3.png

Pedro Villavicencio (pedro) wrote :

Verification done:

- before install app-install-data-commercial: followed the test case, launched gnome-app-install, switched to Third party applications and there's no zdesktop package there.
- after installed the app-install-data-commercial from proposed: followed the test case, launched the gnome-app-install, switch to "Third party applications", the zdesktop (Zimbra Desktop Installer) package is listed there, installing the package and while doing it a browser is open and redirected to the Ubuntu and Zimbra web page after filling the information and closing the browser the package is installed.

Pedro Villavicencio (pedro) wrote :

The package description is shown correctly here i don't get a blank one.

Vadim Peretokin (vperetokin) wrote :

Additionally, I couldn't install the app because it said I'm on 64bit. This might be the case for the missing description, although it doesn't make much sense if it is.

Matt Neilson (ichthyoboy) wrote :

I am missing the description as well, and I am on i386.

Vadim Peretokin (vperetokin) wrote :

I guess we're back to the starting point then.

Michael Vogt (mvo) wrote :

The fact that the app does not install on amd64 is ok, its only available on i386.

Michael Vogt (mvo) wrote :

However it should display a note that its not available on amd64. That is a typo in the package, I'm fixing it in bzr and upload a new version.

Martin Pitt (pitti) wrote :

Approved fixed version into hardy-proposed.

Pedro Villavicencio (pedro) wrote :

I've verified the new proposed package with the same steps as per comment 6 (https://bugs.edge.launchpad.net/ubuntu/+source/app-install-data-commercial/+bug/255666/comments/6) , the package gets installed without any issues, thanks.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in app-install-data-commercial:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers