Does not start with 3.x kernel

Bug #878729 reported by Meik Sievertsen on 2011-10-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apf-firewall (Ubuntu)
Undecided
Unassigned

Bug Description

apf-firewall checks the kernel version if it matches 2.4 or 2.6 and quits if the kernel has a different version (due to the module extension set to "o" or "ko" respectively.

Because oneiric uses the 3.0.x kernel, apf-firewall does not start and errors out with the "Kernel version not equal to 2.4.x or 2.6.x, aborting." error.

Since 3.0.x uses the same extension as 2.6.x a simple fix would be to extend the check and simply add 3.0.x to the list.

The corresponding code is located in /etc/apf-firewall/internals/functions.apf, lines 68 ff. A proposed fix could be to add the following check after the 2.6 check:

elif [ "$KREL" == "3.0" ]; then
    MEXT="ko"

or changing the 2.6 check to use OR. BTW, it looks like the next few lines are not needed (the else is enough).

Thanks for reading the report. :)

Release: Ubuntu 11.10
Package version: 9.7+rev1-3

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apf-firewall (Ubuntu):
status: New → Confirmed
Muh Muhowic (ultrabla) wrote :

confirmed.
rendering the package unusable
ubuntu 12.04 and 12.10

ubuntujoe (jchamb3) wrote :

ubuntu 14.04 as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers