Apache cache serving partial content 206 responses to requests for the full content

Bug #908583 reported by Henk Bokhoven on 2011-12-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Debian)
Fix Released
Unknown
apache2 (Ubuntu)
Wishlist
Unassigned

Bug Description

Apache is caching 206 responses.
This is a known bug: https://issues.apache.org/bugzilla/show_bug.cgi?id=49113
has been fixed in the trunk (http://svn.apache.org/viewvc?view=revision&revision=933919) but not in 2.2.1x

[1] Description: Ubuntu 10.04.3 LTS, Release: 10.04
[2] Package: latest apache2 / apache2-mpm-worker 2.2.14-5ubuntu8.7
[3] Expected to happen:
HEAD "http://example.com/filename.swf"
200 OK
Cache-Control: max-age=604800
Connection: close

[4] What happened instead:
HEAD "http://example.com/filename.swf"
206 Partial Content
Cache-Control: max-age=604800

Cleaned up the cached file by hand from the CacheRoot

My advise: apply the 2 patches as discussed here:

http://svn.apache.org/viewvc/httpd/httpd/branches/2.2.x/STATUS?view=markup&pathrev=1165626

That makes: http://people.apache.org/~minfrin/httpd-cache-partial-2.2.patch
and
http://people.apache.org/~minfrin/httpd-cache-partial2-2.2.patch

Chuck Short (zulcss) wrote :

Thanks this will be considered for the LTS, however it needs to be confirmed in oneiric first, are you available to see if its fixed in oneiric?

Changed in apache2 (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Henk Bokhoven (bokh) wrote :

Thanks Chuck.
All our production and staging servers run Ubuntu 10.04 LTS, so sadly I'm not able to reproduce this (quickly) on Ubuntu 11.10 (Oneiric Ocelot).

Changed in apache2 (Debian):
status: Unknown → New
Changed in apache2 (Debian):
status: New → Confirmed
Changed in apache2 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.