Upgrade from 2.2.14-5ubuntu6 to 2.2.14-5ubuntu7 results in syntax error, missing module

Bug #562370 reported by Kow on 2010-04-13
170
This bug affects 36 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Critical
Chuck Short
Lucid
Critical
Chuck Short

Bug Description

Binary package hint: apache2

When upgrading lucid today I received this error during apache restart in the install process:
Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/reqtimeout.load: Cannot load /usr/lib/apache2/modules/mod_reqtimeout.so into server: /usr/lib/apache2/modules/mod_reqtimeout.so: cannot open shared object file: No such file or directory

The error appears to be part of this change:
  * debian/rules, debian/patches/209-backport-mod-reqtimeout.dpatch,
    debian/config2-dir/mods-available/reqtimeout.load,
    debian/config2-dir/mods-available/reqtimeout.conf debian/NEWS : Backport the
    mod-reqtimeout module from 2.2.15, this will mitigate apache slowloris
    bug in apache. Enable it by default. (LP: #392759)

The module does not appear to exist: /usr/lib/apache2/modules/mod_reqtimeout.so

Related branches

Chris Jones (cmsj) on 2010-04-13
Changed in apache2 (Ubuntu):
status: New → Confirmed

This happened to me also. I can confirm everything that was stated above, the file is indeed missing.

Hung Tran (hungtran) wrote :

I have just updated and got the same error. I can't find /usr/lib/apache2/modules/mod_reqtimeout.so.

On Tue, Apr 13, 2010 at 03:32:00PM -0000, Kow wrote:

> The module does not appear to exist:
> /usr/lib/apache2/modules/mod_reqtimeout.so
>

  importance critical
  assignee zulcss

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Changed in apache2 (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
importance: Undecided → Critical
mars_fish@yahoo.cn (mars-fish) wrote :

Me too. what shall I do

Lito (lito-eordes) wrote :

You can comment line 1 in /etc/apache2/mods-enabled/reqtimeout.load with a # and then restart apache

Dimitrios Ntoulas (ntoulasd) wrote :

Me too
* Starting web server apache2
apache2: Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/reqtimeout.load: Cannot load /usr/lib/apache2/modules/mod_reqtimeout.so into server: /usr/lib/apache2/modules/mod_reqtimeout.so: cannot open shared object file: No such file or directory
   ...fail!

Ed Madrigal (madrigal-ed) wrote :

#5 solution worked for me, apache is working properly again.

Oliver Smith (oliversmith) wrote :

The best way to work around this is to disable the reqtimeout module temporarily using

sudo a2dismod reqtimeout

then all will work, when this bug is fixed it can be re-enabled using

sudo a2enmod reqtimeout

It's easier to remember how to reverse the change if you use the apache too in the first place

Mathias Gug (mathiaz) on 2010-04-13
Changed in apache2 (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.2.14-5ubuntu8

---------------
apache2 (2.2.14-5ubuntu8) lucid; urgency=low

  * debian/patches/210-backport-mod-reqtimeout-ftbfs.dpatch: Add missing mod_reqtime.so
    (LP: #562370)
 -- Chuck Short <email address hidden> Tue, 13 Apr 2010 15:09:57 -0400

Changed in apache2 (Ubuntu Lucid):
status: Confirmed → Fix Released
Ramiro Jr. Franco (rjfranco) wrote :

I'm sort of new here, I'm still receiving this issue even though it says the fix has been released, does this take a while to propagate to the apt servers?

Not normally, did you try the fix on #5. Simply commenting that line out got
me back on track.

On Tue, Apr 13, 2010 at 5:09 PM, Ramiro Jr. Franco <email address hidden>wrote:

> I'm sort of new here, I'm still receiving this issue even though it says
> the fix has been released, does this take a while to propagate to the
> apt servers?
>
> --
> Upgrade from 2.2.14-5ubuntu6 to 2.2.14-5ubuntu7 results in syntax error,
> missing module
> https://bugs.launchpad.net/bugs/562370
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “apache2” package in Ubuntu: Fix Released
> Status in “apache2” source package in Lucid: Fix Released
>
> Bug description:
> Binary package hint: apache2
>
> When upgrading lucid today I received this error during apache restart in
> the install process:
> Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line
> 1 of /etc/apache2/mods-enabled/reqtimeout.load: Cannot load
> /usr/lib/apache2/modules/mod_reqtimeout.so into server:
> /usr/lib/apache2/modules/mod_reqtimeout.so: cannot open shared object file:
> No such file or directory
>
> The error appears to be part of this change:
> * debian/rules, debian/patches/209-backport-mod-reqtimeout.dpatch,
> debian/config2-dir/mods-available/reqtimeout.load,
> debian/config2-dir/mods-available/reqtimeout.conf debian/NEWS : Backport
> the
> mod-reqtimeout module from 2.2.15, this will mitigate apache slowloris
> bug in apache. Enable it by default. (LP: #392759)
>
> The module does not appear to exist:
> /usr/lib/apache2/modules/mod_reqtimeout.so
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/562370/+subscribe
>

Ed Madrigal (madrigal-ed) wrote :

Also did you:

sudo apt-get update

On Tue, Apr 13, 2010 at 8:09 PM, Ed Madrigal <email address hidden> wrote:

> Not normally, did you try the fix on #5. Simply commenting that line out
> got me back on track.
>
>
>
> On Tue, Apr 13, 2010 at 5:09 PM, Ramiro Jr. Franco <email address hidden>wrote:
>
>> I'm sort of new here, I'm still receiving this issue even though it says
>> the fix has been released, does this take a while to propagate to the
>> apt servers?
>>
>> --
>> Upgrade from 2.2.14-5ubuntu6 to 2.2.14-5ubuntu7 results in syntax error,
>> missing module
>> https://bugs.launchpad.net/bugs/562370
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in “apache2” package in Ubuntu: Fix Released
>> Status in “apache2” source package in Lucid: Fix Released
>>
>> Bug description:
>> Binary package hint: apache2
>>
>> When upgrading lucid today I received this error during apache restart in
>> the install process:
>> Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on
>> line 1 of /etc/apache2/mods-enabled/reqtimeout.load: Cannot load
>> /usr/lib/apache2/modules/mod_reqtimeout.so into server:
>> /usr/lib/apache2/modules/mod_reqtimeout.so: cannot open shared object file:
>> No such file or directory
>>
>> The error appears to be part of this change:
>> * debian/rules, debian/patches/209-backport-mod-reqtimeout.dpatch,
>> debian/config2-dir/mods-available/reqtimeout.load,
>> debian/config2-dir/mods-available/reqtimeout.conf debian/NEWS :
>> Backport the
>> mod-reqtimeout module from 2.2.15, this will mitigate apache slowloris
>> bug in apache. Enable it by default. (LP: #392759)
>>
>> The module does not appear to exist:
>> /usr/lib/apache2/modules/mod_reqtimeout.so
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/562370/+subscribe
>>
>
>

Rui Andrada (shingonoide) wrote :

the best workaround solution for the problem is #8 https://bugs.launchpad.net/ubuntu/lucid/+source/apache2/+bug/562370/comments/8
edit the file is not so good.

Use the support command of system:

sudo a2dismod reqtimeout

Just letting everyone know that I received this fix already. Nice turn around time really. Less than a day. And that was from a not so well known package mirror.

tjhunter (tjhunter) wrote :

This still seems to be affecting me. I was having problems with apache, so I removed it completely and tried to reinstall it.

Setting up apache2.2-common (2.2.14-5ubuntu8) ...
ERROR: Module reqtimeout does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1

See attachment for more details.

Steve Langasek (vorlon) wrote :

tjhunter,

Do you have the /etc/apache2/mods-available/reqtimeout.conf file on your system? This config file is provided by this version of apache2.2-common; the error message suggests the file is missing.

tjhunter (tjhunter) wrote :

I did get it working. I removed any and all apache2 related packages including apache2.2-common and reinstalled them. Not sure why apache2.2-common didn't get upgraded automatically. Another thing is that I tried using synaptic instead of aptitude and it seemed to help. Not sure why that would be. Maybe just coincidence.

Ganton (ganton) wrote :

If it can be useful for anyone:

I also got this error:
      ERROR: Module reqtimeout does not exist!

I executed:
      sudo a2dismod reqtimeout
but this did not work for me, it said:
     ERROR: Module reqtimeout does not exist!

The solution told in https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/576255 worked.

yaya (yaya-2013) on 2010-06-22
Changed in apache2 (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
peteacel (pedroacelas) wrote :

apache upgrade to the latest version to be compatible with lucid.
I suppose it is for this reason, generated by the bug.

I ran into this bug *today* 2010-09-22 when updating to latest:

sublime@sublime:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
3 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up apache2.2-common (2.2.14-5ubuntu8.2) ...
ERROR: Module reqtimeout does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1

Egon Willighagen (egonw) wrote :

Same here. Sept 24. :(

Me to, some error. module reqtimeout doens't exist, so "sudo a2enmod reqtimeout" doesn't work.

John Reese (jreese) wrote :

I'm having the same problem on my server. It's not a critical issue, because I can continue running Apache via `service apache2 restart`, but I've attached the update output in hopes that it will somehow help. Would be great to know how to fix this. :)

Ross Golder (ross-golder) wrote :

This worked for me:

'sudo dpkg --purge --force-remove-reinstreq apache2.2-common'

Got it from bug #576255.

John Reese (jreese) wrote :

Ross: running that command doesn't seem to work for me; it complains about all the dependencies I have against apache2.2-common:

root@dyson /srv # dpkg --purge --force-remove-reinstreq apache2.2-common
dpkg: dependency problems prevent removal of apache2.2-common:
 libapache2-mod-fcgid depends on apache2.2-common.
 libapache2-mod-wsgi depends on apache2.2-common; however:
  Package apache2.2-common is to be removed.
 libapache2-svn depends on apache2.2-common.
dpkg: error processing apache2.2-common (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 apache2.2-common

John Reese (jreese) wrote :

Well, from the other bug # you linked, I was able to get enough of a hint to trace this back to a problem of:
I have /etc/apache2 symlinked to another location where I keep all my server configs version controlled in a directory where everything is backed up on a daily basis. Apparently apt at some point created /etc/apache2.dist and started stuffing things there rather than following the symlink, which is what it used to do just fine... It was just a matter of copying over the reqtimeout.* from that other location into my existing /etc/apache2/mods-available and re-running the install.

Dan Lui (danlui02) wrote :

Hi, I'm also hitting this issue, and its been weeks and I still haven't found a solution. I can't seem to remove apache2.2-common.

superjoey@dirtysnowball:~$ sudo dpkg --purge --force-remove-reinstreq apache2.2-common
dpkg: dependency problems prevent removal of apache2.2-common:
 libapache2-mod-php5 depends on apache2.2-common; however:
  Package apache2.2-common is to be removed.
dpkg: error processing apache2.2-common (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 apache2.2-common

Please help, TIA
-Dan

Thomas Dahlmann (dahlmann) wrote :

I had this error for a while:

Setting up apache2.2-common (2.2.14-5ubuntu8.2) ...
ERROR: Module reqtimeout does not exist!
dpkg: error processing apache2.2-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apache2-suexec:
 apache2-suexec depends on apache2.2-common; however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-suexec (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2-mpm-itk:
 apache2-mpm-itk depends on apache2.2-common (= 2.2.14-5ubuntu8.2); however:
  Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-itk (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                           No apport report written because the error message indicates its a followup error from a previous failure.
                                                      Errors were encountered while processing:
 apache2.2-common
 apache2-suexec
 apache2-mpm-itk
E: Sub-process /usr/bin/dpkg returned an error code (1)

I solved it by running:

dpkg --purge --force-all apache2.2-common
 dpkg: apache2.2-common: dependency problems, but removing anyway as you requested:
 libapache2-mod-php5 depends on apache2.2-common; however:
 Package apache2.2-common is to be removed.
 libapache2-mod-perl2 depends on apache2.2-common.
 libapache2-mod-auth-mysql depends on apache2.2-common (>= 2.2.3-3).
 libapache2-mod-geoip depends on apache2.2-common.
 (Reading database ... 116204 files and directories currently installed.)
 Removing apache2.2-common ...
 Purging configuration files for apache2.2-common ...
 dpkg: warning: while removing apache2.2-common, directory '/var/www' not empty so not removed.
 dpkg: warning: while removing apache2.2-common, directory '/var/log/apache2' not empty so not removed.
 dpkg: warning: while removing apache2.2-common, directory '/etc/apache2/sites-available' not empty so not removed.
 Processing triggers for man-db ...
 Processing triggers for ureadahead ...
 Processing triggers for ufw ...

Then reinstall it:
root@server:~# apt-get install apache2.2-common

Dan Lui (danlui02) wrote :

Thanks Tom, that worked for me. Much appreciated.

But just to note for anyone else using it, make sure to save your /etc/apache2 directory first. That fix wiped out my configs, good thing I had a backup.

Thomas Dahlmann (dahlmann) wrote :

Sorry, I just found out for my self after a reboot :(

It keeps the configuration files but removes symbolic links to modules and configurationfiles.

I also had to battle with a new ports.conf file which got installed. It added a Listen 443 statement that blocked the Apache server from starting at all. But after commenting it out everything was back in business.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers