"aptitude upgrade apache2" overrides run-level settings

Bug #394967 reported by msfree on 2009-07-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

The apache2 package fails to check whether rc scripts have been modified when performing an upgrade. As a result admins who have disabled boot-time invokation (update-rc.d -f apache2 remove) will be surprised to find that system, package, and other upgrades not only override their configuration, they also start the apache2 daemon. This is not the expected behavior nor is it good security policy (violating the principle of least surprise never is).

Apache2 and other packages should not automatically create links to rc.#d directories when upgrading nor should these packages automatically start processes when doing upgrades.

Please re-file this as an aptitude / synaptic / apt-get / dpkg bug if that is the more appropriate place for requiring postinst, preinst, ... to respect existing system configurations or at least require user-interaction before changing them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers