Need to source envvars before being able to use 'apache2' binary.

Bug #259363 reported by Sander Smeenk
2
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Binary package hint: apache2.2-common

Hi,

It appears you *need* to source /etc/apache2/envvars before being able to interact with /usr/sbin/apache2 from the shell.
This is annoying.

| $ /usr/sbin/apache2 -S
| apache2: bad user name ${APACHE_RUN_USER}
| $ . /etc/apache2/envvars
| $ /usr/sbin/apache2 -S
| [ .. expected output .. ]

Is this really the best way to make the APACHE_RUN_USER configurable?
How about sourcing /etc/apache2/conf.d/run-as-user or something that is included when apache2ctl or apache2 is run.

Ubuntu Hardy 8.04.1 AMD64, Apache2 (2.2.8-1ubuntu0.3)

Regards,
Sander.

Revision history for this message
Chuck Short (zulcss) wrote :

Thanks,

Ill take a look at this for intrepid.

Regards
chuck

Changed in apache2:
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Stefan Fritsch (sf-sfritsch) wrote :

You can use apache2ctl to pass arbitrary options to apache2. Things like

apache2ctl -S
apache2ctl -DSOMETHING -X

work without sourcing the envvars file. Probably this should be documented more clearly in README.Debian and/or the man page.

The alternatives to using envvars for the run user and pid file have different problems and are not really an improvement.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.2.9-10ubuntu1

---------------
apache2 (2.2.9-10ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/{control, rules}: enable PIE hardening.
    - debian/{control, rules, apache2.2-common.ufw.profile}: add ufw profiles.

apache2 (2.2.9-10) unstable; urgency=low

  * Regression fix from upstream svn for mod_proxy_http:
    Don't trigger a retry by the client if a failure to read the response line
    was the result of a timeout.

apache2 (2.2.9-9) unstable; urgency=medium

  * Revert the attempted fix for #496080 because it did not work due to
    upstream PR 38330. Instead, document the problem and possible workarounds
    in README.Debian.

apache2 (2.2.9-8) unstable; urgency=low

  * Fix Spanish language support which was broken by .es being added to
    /etc/mime.types for application/ecmascript. (Closes: #496080)
  * Correct description of ServerTokens in /etc/apache2/conf.d/security.
    (Closes: #497362)
  * Clarify how to use apache2ctl to pass arbitrary arguments to
    apache2. (LP: #259363)
  * Add hints to README.Debian about the messages
    "NameVirtualHost *:80 has no VirtualHosts" and
    "File does not exist: /htdocs".

 -- Chuck Short <email address hidden> Wed, 05 Nov 2008 02:23:18 -0400

Changed in apache2:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers