Re-merge apache2 for jammy

Bug #1959924 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Fix Released
Undecided
Bryce Harrington

Bug Description

Apache2 2.4.51-2 is already merged into jammy, which also includes backport of OpenSSL3 support from upstream. There is a new 2.4.52 release that includes this OpenSSL3 support (and a few associated fixes/cleanups further), which is available currently from Debian unstable as 2.4.52-1.

Also note that Debian experimental carries a -3 version which includes changes needed to move from pcre3 to the better supported pcre2, which is needed for LP: #1792544.

 apache2 | 2.4.48-3.1ubuntu3 | impish
 apache2 | 2.4.48-3.1ubuntu3.2 | impish-security
 apache2 | 2.4.48-3.1ubuntu3.2 | impish-updates
 apache2 | 2.4.51-2ubuntu1 | jammy

apache2 | 2.4.46-1~bpo9+1 | stretch-backports-sloppy
apache2 | 2.4.46-1~bpo9+1 | stretch-backports-sloppy-debug
apache2 | 2.4.51-1~bpo10+2 | buster-backports
apache2 | 2.4.51-1~bpo10+2 | buster-backports-debug
apache2 | 2.4.51-1~deb11u1 | stable
apache2 | 2.4.51-1~deb11u1 | stable-debug
apache2 | 2.4.52-1~deb11u2 | proposed-updates
apache2 | 2.4.52-1~deb11u2 | proposed-updates-debug
apache2 | 2.4.52-1 | testing
apache2 | 2.4.52-1 | unstable
apache2 | 2.4.52-1 | unstable-debug
apache2 | 2.4.52-3 | experimental
apache2 | 2.4.52-3 | experimental-debug

Tags: needs-merge

Related branches

Bryce Harrington (bryce)
tags: added: needs-merge
Changed in apache2 (Ubuntu):
milestone: none → ubuntu-22.03
description: updated
Bryce Harrington (bryce)
Changed in apache2 (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apache2 - 2.4.52-1ubuntu1

---------------
apache2 (2.4.52-1ubuntu1) jammy; urgency=medium

  * Merge with Debian unstable (LP: #1959924). Remaining changes:
    - debian/{control, apache2.install, apache2-utils.ufw.profile,
      apache2.dirs}: Add ufw profiles.
      (LP 261198)
    - debian/apache2.py, debian/apache2-bin.install: Add apport hook.
      (LP 609177)
    - d/index.html, d/icons/ubuntu-logo.png, d/apache2.postrm,
      d/s/include-binaries: replace Debian with Ubuntu on default
      page and add Ubuntu icon file.
      (LP 1288690)
  * Dropped:
    - d/p/support-openssl3-*.patch: Backport various patches from
      https://github.com/apache/httpd/pull/258 in order to fix mod_ssl's
      failure to load when using OpenSSL 3.
      (LP #1951476)
      [Included in upstream release 2.4.52]
    - d/apache2ctl: Also use systemd for graceful if it is in use.
      (LP 1832182)
      [This introduced a performance regression.]
    - d/apache2ctl: Also use /run/systemd to check for systemd usage.
      (LP 1918209)
      [Not needed]

 -- Bryce Harrington <email address hidden> Thu, 03 Feb 2022 10:25:47 -0800

Changed in apache2 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers