rpackage apache2 2.4.46-4ubuntu1.3 failed to install/upgrade: installed apache2 package post-installation script subprocess returned error exit status 1

Bug #1947204 reported by William Massey

This bug report will be marked for expiration in 13 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

i'm not quite sure what happened. I just upgraded to the latest ubuntu server 21.10 from 21.04, and an error with apache2 came up.
I use ubuntu server to host nextcloud snap, and a vpn, and i have apache2 running for personal testing. I have apache running on port 8080 because i have nextcloud running on port 80

ProblemType: Package
DistroRelease: Ubuntu 21.04
Package: apache2 2.4.46-4ubuntu1.3
ProcVersionSignature: Ubuntu 5.4.0-1044.48-raspi 5.4.140
Uname: Linux 5.4.0-1044-raspi aarch64
000-default.conf: Error: [Errno 40] Too many levels of symbolic links: '/etc/apache2/sites-enabled/000-default.conf'
Apache2ConfdDirListing: False
Apache2Modules: httpd (pid 1224069) already running
ApportVersion: 2.20.11-0ubuntu65.3
Architecture: arm64
CasperMD5CheckResult: unknown
Date: Thu Oct 14 21:37:47 2021
ErrorMessage: installed apache2 package post-installation script subprocess returned error exit status 1
ImageMediaBuild: 20210819.1
Python3Details: /usr/bin/python3.9, Python 3.9.5, python3-minimal, 3.9.4-1
PythonDetails: N/A
RebootRequiredPkgs: Error: path contained symlinks.
RelatedPackageVersions:
 dpkg 1.20.9ubuntu1
 apt 2.2.4ubuntu0.1
SourcePackage: apache2
Title: package apache2 2.4.46-4ubuntu1.3 failed to install/upgrade: installed apache2 package post-installation script subprocess returned error exit status 1
UpgradeStatus: Upgraded to hirsute on 2021-10-14 (0 days ago)
error.log:
 [Thu Oct 14 00:00:02.277491 2021] [mpm_event:notice] [pid 832125:tid 281472857456656] AH00489: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
 [Thu Oct 14 00:00:02.277573 2021] [core:notice] [pid 832125:tid 281472857456656] AH00094: Command line: '/usr/sbin/apache2'
 [Thu Oct 14 20:40:59.986667 2021] [mpm_event:notice] [pid 832125:tid 281472857456656] AH00491: caught SIGTERM, shutting down
 [Thu Oct 14 20:41:00.153257 2021] [mpm_event:notice] [pid 1224069:tid 281473278185488] AH00489: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
 [Thu Oct 14 20:41:00.154120 2021] [core:notice] [pid 1224069:tid 281473278185488] AH00094: Command line: '/usr/sbin/apache2'
modified.conffile..etc.apache2.ports.conf: [modified]
modified.conffile..etc.apache2.sites-available.000-default.conf: [modified]
mtime.conffile..etc.apache2.ports.conf: 2021-10-11T04:33:34.377663
mtime.conffile..etc.apache2.sites-available.000-default.conf: 2021-10-11T04:33:07.121768

Revision history for this message
William Massey (wm31415926) wrote :
Revision history for this message
Utkarsh Gupta (utkarsh) wrote :

Hello,

Thank you for taking the time to file a bug report.

We will need more information in order to proceed with the investigation of the bug. Based on the logs posted, I could not determine the cause for the error message.

When I repeat the steps described in the DpkgHistoryLog.log in a Focal container, namely:

# apt-get install apache2
# apt-get purge apache2
# apt-get autoremove --purge
# apt-get install apache2

Everything works as expected. Bear in mind, I have not modified any configuration file when running these tests. Therefore, I would like to ask you to provide:

1) More log files, especifically the Apache2 ones: /var/log/apache2/*, and "journalctl -u apache2.service".

2) Any custom configuration files for Apache2 that you might have.

Since there is not enough information in your report to begin triage or to
differentiate between a local configuration problem and a bug in Ubuntu, I
am marking this bug as "Incomplete". We would be grateful if you would:
provide a more complete description of the problem, explain why you
believe this is a bug in Ubuntu rather than a problem specific to your
system, and then change the bug status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
Revision history for this message
Utkarsh Gupta (utkarsh) wrote :

That said, one plausible workaround for this would be:

# apt purge apache2*
# apt install apache2

Let me know what you think and if that works for you?

Revision history for this message
William Massey (wm31415926) wrote : Re: [Bug 1947204] rpackage apache2 2.4.46-4ubuntu1.3 failed to install/upgrade: installed apache2 package post-installation script subprocess returned error exit status 1
Download full text (4.5 KiB)

I just removed apache and added it again. Thank you

> On 19/10/2021, at 2:15 AM, Utkarsh Gupta <email address hidden> wrote:
>
> Hello,
>
> Thank you for taking the time to file a bug report.
>
> We will need more information in order to proceed with the investigation
> of the bug. Based on the logs posted, I could not determine the cause
> for the error message.
>
> When I repeat the steps described in the DpkgHistoryLog.log in a Focal
> container, namely:
>
> # apt-get install apache2
> # apt-get purge apache2
> # apt-get autoremove --purge
> # apt-get install apache2
>
> Everything works as expected. Bear in mind, I have not modified any
> configuration file when running these tests. Therefore, I would like to
> ask you to provide:
>
> 1) More log files, especifically the Apache2 ones: /var/log/apache2/*,
> and "journalctl -u apache2.service".
>
> 2) Any custom configuration files for Apache2 that you might have.
>
> Since there is not enough information in your report to begin triage or to
> differentiate between a local configuration problem and a bug in Ubuntu, I
> am marking this bug as "Incomplete". We would be grateful if you would:
> provide a more complete description of the problem, explain why you
> believe this is a bug in Ubuntu rather than a problem specific to your
> system, and then change the bug status back to "New".
>
> For local configuration issues, you can find assistance here:
> http://www.ubuntu.com/support/community
>
>
> ** Changed in: apache2 (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1947204
>
> Title:
> rpackage apache2 2.4.46-4ubuntu1.3 failed to install/upgrade:
> installed apache2 package post-installation script subprocess returned
> error exit status 1
>
> Status in apache2 package in Ubuntu:
> Incomplete
>
> Bug description:
> i'm not quite sure what happened. I just upgraded to the latest ubuntu server 21.10 from 21.04, and an error with apache2 came up.
> I use ubuntu server to host nextcloud snap, and a vpn, and i have apache2 running for personal testing. I have apache running on port 8080 because i have nextcloud running on port 80
>
> ProblemType: Package
> DistroRelease: Ubuntu 21.04
> Package: apache2 2.4.46-4ubuntu1.3
> ProcVersionSignature: Ubuntu 5.4.0-1044.48-raspi 5.4.140
> Uname: Linux 5.4.0-1044-raspi aarch64
> 000-default.conf: Error: [Errno 40] Too many levels of symbolic links: '/etc/apache2/sites-enabled/000-default.conf'
> Apache2ConfdDirListing: False
> Apache2Modules: httpd (pid 1224069) already running
> ApportVersion: 2.20.11-0ubuntu65.3
> Architecture: arm64
> CasperMD5CheckResult: unknown
> Date: Thu Oct 14 21:37:47 2021
> ErrorMessage: installed apache2 package post-installation script subprocess returned error exit status 1
> ImageMediaBuild: 20210819.1
> Python3Details: /usr/bin/python3.9, Python 3.9.5, python3-minimal, 3.9.4-1
> PythonDetails: N/A
> RebootRequiredPkgs: Error: path contained symlinks.
> RelatedPackageVersions:
> dpkg 1.20.9ubuntu1
> apt 2.2.4ubuntu0.1
> SourcePackage: apache2
> Titl...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers