Support more modern Lua versions - to keep only one in main

Bug #1910372 reported by Christian Ehrhardt  on 2021-01-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Debian)
Unknown
Unknown
apache2 (Ubuntu)
Undecided
Unassigned
dovecot (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
in the past we have tried to move 5.1->5.2 (bug 1324062) but right now we have:
For older Lua versions being held in main I found:
- apache2-bin depends on lua5.2
- dovecot depends depends on lua5.3
And a request for lua5.4 in bug 1909665.

Step I:

I'd request to check if we can:
- at least move apache2 to lua5.3 to be able to demote lua5.2 in Hirsute
- [1] suggests that 5.3 might work right away

Step II:

Further down the road I'd request to check and work on moving dovecot+apache2 to lua5.4 (unless it turns out impossible). Then we could completely move to 5.4 and demote 5.3 as well.
And we could make ibus-libpinyin a sync again then (see bug 1909665).

[1]: https://git.launchpad.net/ubuntu/+source/apache2/tree/modules/lua/config.m4?h=applied/ubuntu/hirsute#n37

Paride Legovini (paride) wrote :

I verified that apache2 builds fine against lua5.3 and filed [1] in Debian. This is similar to [2] and the apache2 maintainers promptly bumped the build-dep back then.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=979501
[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=820243

Paride Legovini (paride) wrote :

(I also verified that apache2 does *not* build against lua5.4)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.