package apache2 2.4.41-4ubuntu3.1 failed to install/upgrade: podproces zainstalowany pakiet apache2 skrypt post-installation zwrócił kod błędu 1

Bug #1910096 reported by Michael Hayboek on 2021-01-04

This bug report will be marked for expiration in 45 days if no further activity occurs. (find out why)

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

I want to install apache2 and configure it to .cgi scripts but always something going wrong at installation. Before i was have '403 Forbiden' error, but now after reinstallation i have 'internet connection' error. Please help

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: apache2 2.4.41-4ubuntu3.1
ProcVersionSignature: Ubuntu 5.4.0-58.64-generic 5.4.73
Uname: Linux 5.4.0-58-generic x86_64
Apache2ConfdDirListing: False
Apache2Modules:
 Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: AH00526: Syntax error on line 162 of /etc/apache2/apache2.conf:
 Invalid command 'Require', perhaps misspelled or defined by a module not included in the server configuration
 Action '-D DUMP_MODULES' failed.
 The Apache error log may have more information.
ApportVersion: 2.20.11-0ubuntu27.14
AptOrdering:
 apache2-bin:amd64: Install
 apache2-utils:amd64: Install
 apache2:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Jan 4 13:36:22 2021
ErrorMessage: podproces zainstalowany pakiet apache2 skrypt post-installation zwrócił kod błędu 1
InstallationDate: Installed on 2020-11-06 (58 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.2ubuntu0.2
SourcePackage: apache2
Title: package apache2 2.4.41-4ubuntu3.1 failed to install/upgrade: podproces zainstalowany pakiet apache2 skrypt post-installation zwrócił kod błędu 1
UpgradeStatus: No upgrade log present (probably fresh install)
error.log: Error: [Errno 2] Nie ma takiego pliku ani katalogu: '/var/log/apache2/error.log'

Michael Hayboek (rocketfuell) wrote :

Thank you for taking the time to file a bug report.

I was not able to get many insights from the attached logs due to the language, but I can see this:

Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: AH00526: Syntax error on line 162 of /etc/apache2/apache2.conf:
 Invalid command 'Require', perhaps misspelled or defined by a module not included in the server configuration

Could you please share your /etc/apache2/apach2.conf?

Since it seems likely to me that this is a local configuration problem,
rather than a bug in Ubuntu, I am marking this bug as 'Incomplete'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers