package php7.3-common 7.3.11-0ubuntu0.19.10.3 failed to install/upgrade: installed php7.3-common package post-installation script subprocess returned error exit status 10

Bug #1869957 reported by Sergey on 2020-03-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello, all problem come from this

I many many time remove and again install, nothing help

#####################################################

apache2: Syntax error on line 146 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/authz_host.load: Cannot load /usr/lib/apache2/modules/mod_authz_host.so into server: /usr/lib/apache2/modules/mod_authz_host.so: invalid ELF header
Action 'start' failed.
The Apache error log may have more information.

######################################################

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2020-04-01 00:16:16 +04; 33s ago
     Docs: https://httpd.apache.org/docs/2.4/
  Process: 22072 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

Ապր 01 00:16:14 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx systemd[1]: Starting The Apache HTTP Server...
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx apachectl[22072]: apache2: Syntax error on line 146 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/authz_host.
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx apachectl[22072]: Action 'start' failed.
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx apachectl[22072]: The Apache error log may have more information.
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx systemd[1]: apache2.service: Failed with result 'exit-code'.
Ապր 01 00:16:16 sergey-HP-Pavilion-Gaming-Laptop-15-cx0xxx systemd[1]: Failed to start The Apache HTTP Server.

ProblemType: Package
DistroRelease: Ubuntu 19.10
Package: php7.3-common 7.3.11-0ubuntu0.19.10.3
ProcVersionSignature: Ubuntu 5.3.0-46.38-generic 5.3.18
Uname: Linux 5.3.0-46-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu8.7
Architecture: amd64
Date: Wed Apr 1 00:10:44 2020
ErrorMessage: installed php7.3-common package post-installation script subprocess returned error exit status 10
InstallationDate: Installed on 2020-03-14 (17 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
Python3Details: /usr/bin/python3.7, Python 3.7.5, unpackaged
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu2
 apt 1.9.4
SourcePackage: php7.3
Title: package php7.3-common 7.3.11-0ubuntu0.19.10.3 failed to install/upgrade: installed php7.3-common package post-installation script subprocess returned error exit status 10
UpgradeStatus: No upgrade log present (probably fresh install)

Sergey (serguynya) wrote :

Hello Sergey,

Have you tried removing the package entirely:

$ sudo apt-get remove --purge apache2

$ sudo apt-get --purge autoremove

removing the cache:

$ sudo rm /var/cache/apt/archives/*apache2*

making sure to have -updates repository:

# /etc/apt/sources.list

deb http://us.archive.ubuntu.com/ubuntu eoan main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu eoan main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu eoan-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu eoan-updates main restricted universe multiverse
deb http://us.archive.ubuntu.com/ubuntu eoan-proposed main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu eoan-proposed main restricted universe multiverse

updating:

$ sudo apt-get update

and installing latest version ?

$ sudo apt-get install apache2

I could not reproduce this issue in Eoan

Thank you for taking the time to file a bug report.

Since it seems likely to me that this is a local configuration problem,
rather than a bug in Ubuntu, I am marking this bug as 'Incomplete'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in php7.3 (Ubuntu Eoan):
status: New → Incomplete
no longer affects: php7.3 (Ubuntu Eoan)
no longer affects: php7.3 (Ubuntu)
Changed in apache2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apache2 (Ubuntu) because there has been no activity for 60 days.]

Changed in apache2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers