Apache 2.4.39 update for eoan

Bug #1834359 reported by Bryce Harrington on 2019-06-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream has released Apache 2.4.39, but this is not yet in debian unstable/experimental. Debian does have a branch though, with refreshed patches:

  https://salsa.debian.org/apache-team/apache2/blob/apache-2.4.39/debian/changelog

The 2.4.39 release includes a new config option MergeSlashes, a number of Apache mod changes, and a couple other changes:

  https://salsa.debian.org/apache-team/apache2/blob/apache-2.4.39/CHANGES

There has been interest in the mod_reqtimeout change to add (TLS-)handshake timeout support (see LP: #1833781).

Ubuntu disco is on 2.4.38, and presumably Ubuntu server will want something newer than that in 20.04, so there may be testing value in moving eoan to 2.4.39.

Jesse Williamson (chardan) wrote :

As has been pointed out, having the mod_reqtimeout TLS handshake feature available would be a welcome effect of choosing this version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers