package apache2 2.4.29-1ubuntu4.2 failed to install/upgrade: Unterprozess installed apache2 package post-installation script gab den Fehler-Ausgangsstatus 1 zurück

Bug #1782877 reported by Horst Buley on 2018-07-21

This bug report will be marked for expiration in 5 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

lsb_release -rd
Description: Ubuntu 18.04 LTS
Release: 18.04

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: apache2 2.4.29-1ubuntu4.2
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
Apache2ConfdDirListing: False
Apache2Modules: httpd (pid 1171) already running
ApportVersion: 2.20.9-0ubuntu7.2
AptOrdering:
 linux-generic-hwe-16.04:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Sat Jul 21 06:57:38 2018
ErrorMessage: Unterprozess installed apache2 package post-installation script gab den Fehler-Ausgangsstatus 1 zurück
InstallationDate: Installed on 2018-02-24 (146 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3ubuntu1
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.2
SourcePackage: apache2
Title: package apache2 2.4.29-1ubuntu4.2 failed to install/upgrade: Unterprozess installed apache2 package post-installation script gab den Fehler-Ausgangsstatus 1 zurück
UpgradeStatus: Upgraded to bionic on 2018-05-02 (80 days ago)
modified.conffile..etc.apache2.apache2.conf: [modified]
modified.conffile..etc.apache2.mods-available.dir.conf: [modified]
modified.conffile..etc.apache2.sites-available.000-default.conf: [modified]
mtime.conffile..etc.apache2.apache2.conf: 2018-04-26T07:34:19.000328
mtime.conffile..etc.apache2.mods-available.dir.conf: 2018-04-25T16:30:20.018573
mtime.conffile..etc.apache2.sites-available.000-default.conf: 2018-04-26T07:38:11.004484

Horst Buley (horstbuley) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

information type: Private Security → Public
Andreas Hasenack (ahasenack) wrote :

Thanks for filing this bug in Ubuntu.

This is the error that was reported:
apache2 (2.4.29-1ubuntu4.2) wird eingerichtet ...
info: Executing deferred 'a2enconf apache2-doc' for package apache2-doc
ERROR: Conf apache2-doc does not exist!
dpkg: Fehler beim Bearbeiten des Paketes apache2 (--configure):
 Unterprozess installed apache2 package post-installation script gab den Fehler-Ausgangsstatus 1 zurück

It looks like the apache2-doc package is not fully installed. The package seems to be in the database of installed packages, but one or more of its files in /etc are gone.

I suggest the following:

sudo apt update
sudo apt install apache2-doc

If that doesn't fix it, try:

sudo apt install --reinstall apache2-doc

Or, if you don't want it, just purge it:

sudo apt purge apache2-doc

In any case, it's also good to run this at the end to attempt to fix any remaining issues:

sudo apt -f install

Changed in apache2 (Ubuntu):
status: New → Incomplete
Download full text (3.4 KiB)

Thanks For your reply

Andreas Hasenack <email address hidden> schrieb am Di., 31. Juli 2018,
17:01:

> Thanks for filing this bug in Ubuntu.
>
> This is the error that was reported:
> apache2 (2.4.29-1ubuntu4.2) wird eingerichtet ...
> info: Executing deferred 'a2enconf apache2-doc' for package apache2-doc
> ERROR: Conf apache2-doc does not exist!
> dpkg: Fehler beim Bearbeiten des Paketes apache2 (--configure):
> Unterprozess installed apache2 package post-installation script gab den
> Fehler-Ausgangsstatus 1 zurück
>
>
> It looks like the apache2-doc package is not fully installed. The package
> seems to be in the database of installed packages, but one or more of its
> files in /etc are gone.
>
> I suggest the following:
>
> sudo apt update
> sudo apt install apache2-doc
>
> If that doesn't fix it, try:
>
> sudo apt install --reinstall apache2-doc
>
> Or, if you don't want it, just purge it:
>
> sudo apt purge apache2-doc
>
> In any case, it's also good to run this at the end to attempt to fix any
> remaining issues:
>
> sudo apt -f install
>
> ** Changed in: apache2 (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1782877
>
> Title:
> package apache2 2.4.29-1ubuntu4.2 failed to install/upgrade:
> Unterprozess installed apache2 package post-installation script gab
> den Fehler-Ausgangsstatus 1 zurück
>
> Status in apache2 package in Ubuntu:
> Incomplete
>
> Bug description:
> lsb_release -rd
> Description: Ubuntu 18.04 LTS
> Release: 18.04
>
> ProblemType: Package
> DistroRelease: Ubuntu 18.04
> Package: apache2 2.4.29-1ubuntu4.2
> ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
> Uname: Linux 4.15.0-24-generic x86_64
> Apache2ConfdDirListing: False
> Apache2Modules: httpd (pid 1171) already running
> ApportVersion: 2.20.9-0ubuntu7.2
> AptOrdering:
> linux-generic-hwe-16.04:amd64: Install
> NULL: ConfigurePending
> Architecture: amd64
> Date: Sat Jul 21 06:57:38 2018
> ErrorMessage: Unterprozess installed apache2 package post-installation
> script gab den Fehler-Ausgangsstatus 1 zurück
> InstallationDate: Installed on 2018-02-24 (146 days ago)
> InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64
> (20170801)
> Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal,
> 3.6.5-3ubuntu1
> PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal,
> 2.7.15~rc1-1
> RelatedPackageVersions:
> dpkg 1.19.0.5ubuntu2
> apt 1.6.2
> SourcePackage: apache2
> Title: package apache2 2.4.29-1ubuntu4.2 failed to install/upgrade:
> Unterprozess installed apache2 package post-installation script gab den
> Fehler-Ausgangsstatus 1 zurück
> UpgradeStatus: Upgraded to bionic on 2018-05-02 (80 days ago)
> modified.conffile..etc.apache2.apache2.conf: [modified]
> modified.conffile..etc.apache2.mods-available.dir.conf: [modified]
> modified.conffile..etc.apache2.sites-available.000-default.conf:
> [modified]
> mtime.conffile..etc.apache2.apache2.conf: 2018-04-26T07:34:19.000328
> mtime.conffile..etc.apache2.mods-avai...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers