Upgrade from 2.4.18-2ubuntu3.8 to 2.4.18-2ubuntu3.9 fails to restart apache

Bug #1780304 reported by Jay Kuri on 2018-07-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Summary:

On many xenial machines this morning during an update, the apache2 package was upgraded. Upon completion of the upgrade, apache was not restarted causing service outages.

The upgrade was from 2.4.18-2ubuntu3.8 to 2.4.18-2ubuntu3.9.

What I did:

Allowed apache2 to be upgraded.

What I expected:

apache2 would be upgraded and would be restarted to get the new version online.

What happened instead:

apache2 was upgraded, but the apache2.service was not restarted post-upgrade, leaving apache2.service down.

Additional detail:

apt/history.log

Upgrade: libapt-inst2.0:amd64 (1.2.26, 1.2.27), apt:amd64 (1.2.26, 1.2.27), libapt-pkg5.0:amd64 (1.2.26, 1.2.27), apache2-data:amd64 (2.4.18-2ubuntu3.8, 2.4.18-2ubuntu3.9), hponcfg:amd64 (3.1.0.0.18-11.1.IS.10.04, 5.2.0.0-3.0.IS.16.04), libdrm2:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), apt-utils:amd64 (1.2.26, 1.2.27), libdrm-intel1:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), apache2-bin:amd64 (2.4.18-2ubuntu3.8, 2.4.18-2ubuntu3.9), apt-transport-https:amd64 (1.2.26, 1.2.27), libdrm-radeon1:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), apache2:amd64 (2.4.18-2ubuntu3.8, 2.4.18-2ubuntu3.9), apache2-utils:amd64 (2.4.18-2ubuntu3.8, 2.4.18-2ubuntu3.9), libdrm-common:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)

relevant dpkg.log:

2018-07-05 15:47:26 status unpacked apt-utils:amd64 1.2.27
2018-07-05 15:47:26 upgrade apache2:amd64 2.4.18-2ubuntu3.8 2.4.18-2ubuntu3.9
2018-07-05 15:47:26 status half-configured apache2:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status triggers-pending systemd:amd64 229-4ubuntu21.2
2018-07-05 15:47:28 status triggers-pending ureadahead:amd64 0.100.0-19
2018-07-05 15:47:28 status half-installed apache2:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status unpacked apache2:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 upgrade apache2-bin:amd64 2.4.18-2ubuntu3.8 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status half-configured apache2-bin:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-bin:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-bin:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-bin:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-bin:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status unpacked apache2-bin:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 upgrade apache2-utils:amd64 2.4.18-2ubuntu3.8 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status half-configured apache2-utils:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-utils:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-utils:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-utils:amd64 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-utils:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status unpacked apache2-utils:amd64 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 upgrade apache2-data:all 2.4.18-2ubuntu3.8 2.4.18-2ubuntu3.9
2018-07-05 15:47:28 status half-configured apache2-data:all 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-data:all 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-data:all 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status half-installed apache2-data:all 2.4.18-2ubuntu3.8
2018-07-05 15:47:28 status unpacked apache2-data:all 2.4.18-2ubuntu3.9
2018-07-05 15:47:29 status unpacked apache2-data:all 2.4.18-2ubuntu3.9
2018-07-05 15:47:29 upgrade apt-transport-https:amd64 1.2.26 1.2.27

apache error.log:

[Thu Jul 05 15:47:27.114602 2018] [mpm_worker:notice] [pid 5089:tid 140092203992960] AH00295: caught SIGTERM, shutting down

Jay Kuri (jk0ne) on 2018-07-05
Changed in apache2 (Ubuntu):
milestone: none → xenial-updates
milestone: xenial-updates → none
Robie Basak (racb) wrote :

I asked Jay for other logs out of band. My conclusion for now is that the apache2 postinst never ran, possibly due to an unrelated (not in archive) issue, so this is unlikely to be a bug in apache2 packaging.

Changed in apache2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apache2 (Ubuntu) because there has been no activity for 60 days.]

Changed in apache2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers