package apache2 2.4.18-2ubuntu3.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1709186 reported by Adedayo Ademola Yusuff on 2017-08-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

-------- Uninstall Beginning --------
Module: asic0x
Version: 1.0.1
Kernel: 4.8.0-58-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

asic0x.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.8.0-58-generic/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod....

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.8.0-58-generic /boot/vmlinuz-4.8.0-58-generic
update-initramfs: Deleting /boot/initrd.img-4.8.0-58-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.8.0-58-generic /boot/vmlinuz-4.8.0-58-generic
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.10.0-30-generic
Found linux image: /boot/vmlinuz-4.10.0-28-generic
Found initrd image: /boot/initrd.img-4.10.0-28-generic
Found linux image: /boot/vmlinuz-4.10.0-27-generic
Found initrd image: /boot/initrd.img-4.10.0-27-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done
Processing triggers for libc-bin (2.23-0ubuntu9) ...
Setting up apache2 (2.4.18-2ubuntu3.4) ...
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up grub-common (2.02~beta2-36ubuntu3.12) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package grub-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of grub2-common:
 grub2-common depends on grub-common (= 2.02~beta2-36ubuntu3.12); however:
  Package grub-common is not configured yet.

dpkg: error processing package grub2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-pc-bin:
 grub-pc-bin depends on grub-common (= 2.02~beta2-36ubuntu3.12); however:
  Package grub-common is not configured yet.

dpkg: error processing package grub-pc-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-pc:
 grub-pc depends on grub-common (= 2.02~beta2-36ubuntu3.12); however:
  Package grub-common is not configured yet.
 grub-pc depends on grub2-common (= 2.02~beta2-36ubuntu3.12); however:
  Package grub2-common is not configured yet.
 gruNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                              No apport report written because MaxReports is reached already
                                                                                                                                                                            No apport report written because MaxReports is reached already
                                                        b-pc depends on grub-pc-bin (= 2.02~beta2-36ubuntu3.12); however:
  Package grub-pc-bin is not configured yet.

dpkg: error processing package grub-pc (--configure):
 dependency problems - leaving unconfigured
Setting up ntp (1:4.2.8p4+dfsg-3ubuntu5.6) ...
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package ntp (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up whoopsie (0.2.52.5) ...
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package whoopsie (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Setting up kmod (22-1ubuntu5) ...
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package kmod (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-image-4.10.0-30-generic:
 linux-image-4.10.0-30-generic depends on kmod; however:
  Package kmod is not configured yet.

dpkg: error processing package linux-image-4.10.0-30-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-image-extra-4.10.0-30-generic:
 linux-image-extra-4.10.0-30-generic depends on linux-image-4.10.0-30-generic; however:
  Package linux-image-4.10.0-30-generic is not configured yet.

dpkg: error processing package linux-image-extra-4.10.0-30-generic (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-image-generic-hwe-16.04:
 linux-image-generic-hwe-16.04 depends on linux-image-4.10.0-30-generic; however:
  Package linux-image-4.10.0-30-generic is not configured yet.
 linux-image-generic-hwe-16.04 depends on linux-image-extra-4.10.0-30-generic; however:
  Package linux-image-extra-4.10.0-30-generic is not configured yet.

dpkg: error processing package linux-image-generic-hwe-16.04 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of linux-generic-hwe-16.04:
 linux-generic-hwe-16.04 depends on linux-image-generic-hwe-16.04 (= 4.10.0.30.33); however:
  Package linux-image-generic-hwe-16.04 is not configured yet.

dpkg: error processing package linux-generic-hwe-16.04 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up unattended-upgrades (0.90ubuntu0.7) ...
insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package unattended-upgrades (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 apache2
 grub-common
 grub2-common
 grub-pc-bin
 grub-pc
 ntp
 whoopsie
 kmod
 linux-image-4.10.0-30-generic
 linux-image-extra-4.10.0-30-generic
 linux-image-generic-hwe-16.04
 linux-generic-hwe-16.04
 unattended-upgrades
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: apache2 2.4.18-2ubuntu3.4
ProcVersionSignature: Ubuntu 4.10.0-28.32~16.04.2-generic 4.10.17
Uname: Linux 4.10.0-28-generic x86_64
Apache2ConfdDirListing: ['dhelp.conf']
Apache2Modules:
 Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: AH00526: Syntax error on line 9 of /etc/apache2/conf-enabled/ledgersmb.conf:
 Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
 Action '-D DUMP_MODULES' failed.
 The Apache error log may have more information.
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
Date: Mon Jul 31 05:35:16 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2017-04-29 (98 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.24
SourcePackage: apache2
Title: package apache2 2.4.18-2ubuntu3.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
error.log:

tags: removed: need-duplicate-check
Joshua Powers (powersj) wrote :

From log:

insserv: warning: script 'refdb' missing LSB tags and overrides
insserv: There is a loop between service reniced and refdb if stopped
insserv: loop involving service refdb at depth 2
insserv: loop involving service reniced at depth 1
insserv: Stopping refdb depends on reniced and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header

Joshua Powers (powersj) wrote :

Thank you for taking the time to file a bug report.

It appears that there is something in /etc/init.d/ that is causing a
loop, hence why this message is constantly appearing. The message
references reniced and refdb.

Since it seems likely to me that this is a local configuration problem,
rather than a bug in Ubuntu, I am marking this bug as 'Incomplete'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
Andreas Hasenack (ahasenack) wrote :

This is a bug in the refdb-server package. One way to reproduce it is to:

sudo apt update
sudo apt install refdb-server reniced
sudo apt install apache2

apache2 and reniced have lsb headers, but refdb has not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers