package apache2 2.4.18-2ubuntu3.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1700740 reported by Stephen Jones on 2017-06-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Running on Oracle VM 5.1.22 upgrade Ubuntu and Apache automatically after restart w/o installing Guest upgrade.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: apache2 2.4.18-2ubuntu3.3
ProcVersionSignature: Ubuntu 4.4.0-72.93-generic 4.4.49
Uname: Linux 4.4.0-72-generic x86_64
Apache2ConfdDirListing: False
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
Date: Tue Jun 27 11:10:15 2017
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-05-06 (783 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.2.20
SourcePackage: apache2
Title: package apache2 2.4.18-2ubuntu3.3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2016-09-15 (285 days ago)
error.log:
 [Tue Jun 27 10:45:13.583241 2017] [mpm_prefork:notice] [pid 1259] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
 [Tue Jun 27 10:45:13.583344 2017] [core:notice] [pid 1259] AH00094: Command line: '/usr/sbin/apache2'
 [Tue Jun 27 11:00:12.783893 2017] [mpm_prefork:notice] [pid 1259] AH00169: caught SIGTERM, shutting down
modified.conffile..etc.apache2.apache2.conf: [modified]
modified.conffile..etc.apache2.conf-available.serve-cgi-bin.conf: [modified]
modified.conffile..etc.apache2.mods-available.userdir.conf: [modified]
mtime.conffile..etc.apache2.apache2.conf: 2016-12-20T12:37:33.903032
mtime.conffile..etc.apache2.conf-available.serve-cgi-bin.conf: 2016-12-20T14:05:07.694801
mtime.conffile..etc.apache2.mods-available.userdir.conf: 2016-12-20T12:44:23.771770

Stephen Jones (stevejjones32) wrote :
tags: removed: need-duplicate-check
Joshua Powers (powersj) wrote :

From terminal log:

info: Executing deferred 'a2enmod php7.0' for package libapache2-mod-php7.0
ERROR: Module php7.0 does not exist!

Joshua Powers (powersj) wrote :

Adding nacc to see if he has any insight

Andreas Hasenack (ahasenack) wrote :

This is curious indeed. The php7.0 module is in the libapache2-mod-php7.0 package:
root@xenial-apache-php:~# dpkg -L libapache2-mod-php7.0|egrep so$
/usr/lib/apache2/modules/libphp7.0.so

And happily enabled after being installed:
root@xenial-apache-php:~# a2query -m php7.0
php7.0 (enabled by maintainer script)

Could you please try "sudo apt install --reinstall libapache2-mod-php7.0"?

Also please list the contents of /etc/apache2/mods-enabled and /etc/apache2/mods-available.

Changed in apache2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apache2 (Ubuntu) because there has been no activity for 60 days.]

Changed in apache2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers