package apache2 2.4.25-3ubuntu2 failed to install/upgrade: il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1

Bug #1692350 reported by Paolo Sferrazza on 2017-05-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

failed to install/upgrade

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: apache2 2.4.25-3ubuntu2
ProcVersionSignature: Ubuntu 4.10.0-21.23-generic 4.10.11
Uname: Linux 4.10.0-21-generic i686
Apache2ConfdDirListing: False
ApportVersion: 2.20.4-0ubuntu4
AptOrdering:
 apache2:i386: Install
 NULL: ConfigurePending
Architecture: i386
Date: Sun May 21 10:26:05 2017
ErrorMessage: il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
RelatedPackageVersions:
 dpkg 1.18.10ubuntu2
 apt 1.4
SourcePackage: apache2
Title: package apache2 2.4.25-3ubuntu2 failed to install/upgrade: il sottoprocesso installato script di post-installation ha restituito lo stato di errore 1
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.apache2.apache2.conf: [modified]
mtime.conffile..etc.apache2.apache2.conf: 2017-05-21T12:36:51.995714

Paolo Sferrazza (khonsu111) wrote :
Joshua Powers (powersj) wrote :

From terminal log:

Configuring apache2 (2.4.25-3ubuntu2) ...
Enabling module mpm_event.
cp: can not stat of '/usr/share/apache2/default-site/index.html': File or directory does not exist

From journal error log:

mag 21 19:56:32 hostname systemd[1]: Failed to start The Apache HTTP Server.
mag 21 19:56:32 hostname systemd[1]: apache2.service: Failed with result 'exit-code'.

Joshua Powers (powersj) wrote :

Thank you for taking the time to file a bug report.

If this is still an issue, it looks like apache2 complained about a
missing index.html file. It would be good to run
'sudo dpkg --configure -a' and 'sudo apt-get install -f' to see if
or what those command are complaining about.

Since it seems likely to me that this is a local configuration problem,
rather than a bug in Ubuntu, I am marking this bug as 'Incomplete'.

However, if you believe that this is really a bug in Ubuntu, then we would
be grateful if you would provide a more complete description of the problem
with steps to reproduce, explain why you believe this is a bug in Ubuntu
rather than a problem specific to your system, and then change the bug
status back to "New".

For local configuration issues, you can find assistance here:
http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apache2 (Ubuntu) because there has been no activity for 60 days.]

Changed in apache2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers