/usr/sbin/apache2:*** Error in `/usr/sbin/apache2': munmap_chunk(): invalid pointer: ADDR ***

Bug #1660725 reported by errors.ubuntu.com bug bridge on 2017-01-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Status tracked in Groovy
Xenial
Medium
Unassigned
Groovy
Medium
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding apache2. This problem was most recently seen with package version 2.4.18-2ubuntu4, the problem page at https://errors.ubuntu.com/problem/ea0e5025928fb673b88e8b0a74ec85a92629215e contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

Bryce Harrington (bryce) wrote :

From the error tracker, this crash was seen in apache versions between 2.4.6 (Ubuntu 13.10) and 2.4.27 (Ubuntu 17.10) but there have been no instances of the issue on Ubuntu 18.04 or newer. It appears to still exhibit itself in the version published for Ubuntu 16.04, apache2 2.4.18-2ubuntu3.14. There is a .15 in proposed for xenial but it doesn't sound like a fix for this crash. So the issue is still relevant for xenial at least. Indeed, the last occurrence reported was Jan 23, 2020.

The fault occurs in php7.0 code, during the php module shutdown codepath, where a destructor freeing a hash tries to unmap an invalid pointer. Since this occurs during cleanup, it may not have shown noteworthy symptoms, which may be why it stayed around for so long.

Changed in apache2 (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in apache2 (Ubuntu Groovy):
status: Triaged → Fix Released
Changed in apache2 (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers