package apache2.2-bin (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3

Bug #1593532 reported by Amin Niouar on 2016-06-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Error package

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: apache2.2-bin (not installed)
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic i686
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: i386
Date: Sat Jun 11 15:07:52 2016
DuplicateSignature:
 package:apache2.2-bin:(not installed)
 Unpacking apache2.2-bin (2.2.22-1ubuntu1.10) ...
 dpkg: error processing archive /var/cache/apt/archives/apache2.2-bin_2.2.22-1ubuntu1.10_i386.deb (--unpack):
  trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3
ErrorMessage: trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3
InstallationDate: Installed on 2016-06-11 (5 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release i386 (20160420.1)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: apache2
Title: package apache2.2-bin (not installed) failed to install/upgrade: trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3
UpgradeStatus: No upgrade log present (probably fresh install)

Amin Niouar (niouardev) wrote :
tags: removed: need-duplicate-check
Joshua Powers (powersj) wrote :

From log:

 dpkg: error processing archive /var/cache/apt/archives/apache2.2-bin_2.2.22-1ubuntu1.10_i386.deb (--unpack):
  trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3
ErrorMessage: trying to overwrite '/usr/lib/apache2/modules/mod_dir.so', which is also in package apache2-bin 2.4.18-2ubuntu3

Joshua Powers (powersj) wrote :

Thank you for taking the time to report this.

Per the error message above, the package you are trying to install is trying to overwrite a file that already exists on the system. In this case you have apache2 installed and are overwriting with apache2.2

Becuase this is a local issue and not a bug in Ubuntu I am marking this bug as Incomplete. If you believe this to not be the case then we would appreciate if you could provide a more complete description of the problem, explain why you believe this is a bug in Ubuntu rather than a problem specific to your system, and then change the bug status back to New.

You can find pointers to get help for this sort of problem on the community forums: http://www.ubuntu.com/support/community

Changed in apache2 (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for apache2 (Ubuntu) because there has been no activity for 60 days.]

Changed in apache2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers