package apache2 2.4.7-1ubuntu4.10 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1582462 reported by harre on 2016-05-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Occured when upgrade to 14.02

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: apache2 2.4.7-1ubuntu4.10
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
Apache2ConfdDirListing: False
Apache2Modules:
 Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: AH00526: Syntax error on line 3 of /etc/apache2/mods-enabled/musicindex.load:
 Invalid command 'Order', perhaps misspelled or defined by a module not included in the server configuration
 Action '-D DUMP_MODULES' failed.
 The Apache error log may have more information.
ApportVersion: 2.14.1-0ubuntu3.20
AptOrdering:
 apache2: Configure
 apache2-mpm-worker: Configure
Architecture: amd64
Date: Tue May 17 03:13:58 2016
DpkgHistoryLog: Start-Date: 2016-05-17 03:13:56
DpkgTerminalLog:
 Setting up apache2 (2.4.7-1ubuntu4.10) ...
 ERROR: Module musicindex does not exist!
 dpkg: error processing package apache2 (--configure):
  subprocess installed post-installation script returned error exit status 1
DuplicateSignature: package:apache2:2.4.7-1ubuntu4.10:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.6
 apt 1.0.1ubuntu2.13
SourcePackage: apache2
Title: package apache2 2.4.7-1ubuntu4.10 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to trusty on 2016-05-17 (0 days ago)
error.log:
 [Tue May 17 01:42:56 2016] [notice] Apache/2.2.22 (Ubuntu) mod_musicindex/1.3.6 configured -- resuming normal operations
 [Tue May 17 01:50:55 2016] [notice] caught SIGTERM, shutting down

harre (mail-hartmark) wrote :
tags: removed: need-duplicate-check
harre (mail-hartmark) wrote :

Somehow my mods file were missing.

I fixed by these commands:
sudo su
echo "LoadModule musicindex_module /usr/lib/apache2/modules/mod_musicindex.so" > /etc/apache2/mods-available/musicindex.load
cd /etc/apache2/mods-enabled
ln -s ../mods-available/musicindex.conf
ln -s ../mods-available/musicindex.load

Louis Bouchard (louis) wrote :

So please confirm that your failure was caused by a misconfiguration on your environment and not the new version in -proposed.

Kind regards,

...Louis

tags: added: bot-stop-nagging
harre (mail-hartmark) wrote :

Thanks for the reply,

I have no idea to confirm that it is local changes that caused the problem as I overwrote the previous config file.

I have however i recollection of changing the config-file for mediaserver though.

Best regards,
Markus

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers