package apache2 2.4.18-2ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1574255 reported by Ahmed Kamel on 2016-04-24
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
High
siddhant

Bug Description

Errors were encountered while processing:
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: apache2 2.4.18-2ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
Apache2ConfdDirListing: False
Apache2Modules:
 Error: command ['/usr/sbin/apachectl', '-D DUMP_MODULES'] failed with exit code 1: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/mpm_event.load: Cannot load /usr/lib/apache2/modules/mod_mpm_event.so into server: /usr/lib/apache2/modules/mod_mpm_event.so: cannot open shared object file: No such file or directory
 Action '-D DUMP_MODULES' failed.
 The Apache error log may have more information.
ApportVersion: 2.20.1-0ubuntu2
AptOrdering:
 apache2: Install
 apache2: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Sun Apr 24 14:50:09 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-11-19 (156 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.10ubuntu1
SourcePackage: apache2
Title: package apache2 2.4.18-2ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2016-04-22 (1 days ago)
error.log: Error: [Errno 2] No such file or directory: '/var/log/apache2/error.log'

Ahmed Kamel (smart-brute-force) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
Changed in apache2 (Ubuntu):
importance: Undecided → High
Robie Basak (racb) wrote :

From log:

Setting up apache2 (2.4.18-2ubuntu3) ...
Enabling module mpm_event.
cp: cannot stat '/usr/share/apache2/default-site/index.html': No such file or directory
dpkg: error processing package apache2 (--configure):
 subprocess installed post-installation script returned error exit status 1

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

Since it seems likely to me that this is a local configuration problem, rather than a bug in Ubuntu, I'm marking this bug as Incomplete.

If indeed this is a local configuration problem, you can find pointers to get help for this sort of problem here: http://www.ubuntu.com/support/community

Or if you believe that this is really a bug, then you may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem, explain why you believe this is a bug in Ubuntu rather than a problem specific to your system, and then change the bug status back to New.

Changed in apache2 (Ubuntu):
status: Confirmed → Incomplete
siddhant (siddhu) on 2016-08-17
Changed in apache2 (Ubuntu):
assignee: nobody → siddhant (siddhu)
Changed in apache2 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers