Apache2 default installation has lua module but no library

Bug #1432989 reported by Kurt Huwig on 2015-03-17
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apache2 (Ubuntu)
Undecided
Unassigned

Bug Description

Bug 1323930 is marked as "Fix released" but the problem still exists:

If I enable the module "lua" in the apache2 default installation, I cannot start the server:

$ docker run -it --rm ubuntu:trusty bash
root@6b882ad1774a:/# apt-get update
root@6b882ad1774a:/# apt-get install apache2

[...]

root@6b882ad1774a:/# a2enmod lua
Enabling module lua.
To activate the new configuration, you need to run:
  service apache2 restart
root@6b882ad1774a:/# apache2ctl -t
apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/lua.load: Cannot load /usr/lib/apache2/modules/mod_lua.so into server: /usr/lib/apache2/modules/mod_lua.so: cannot open shared object file: No such file or directory
Action '-t' failed.
The Apache error log may have more information.
root@6b882ad1774a:/# service apache2 start
 * Starting web server apache2 *
 * The apache2 configtest failed.
Output of config test was:
apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/lua.load: Cannot load /usr/lib/apache2/modules/mod_lua.so into server: /usr/lib/apache2/modules/mod_lua.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.
root@6b882ad1774a:/# dpkg -l apache2
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=============================-===================-===================-===============================================================
ii apache2 2.4.7-1ubuntu4.4 amd64 Apache HTTP Server

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apache2 (Ubuntu):
status: New → Confirmed
darkom (darko-miletic) wrote :

Working solution for this is to install Apache from backports repository. It contains Apache 2.4.10 that does have working mod_lua.

sudo apt-get install -y -t trusty-backports apache2 apache2-utils libapache2-mod-proxy-html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers